WordPress.org

Ready to get started?Download WordPress

Forums

After Creating new site - new site is not found (4 posts)

  1. timsaxm
    Member
    Posted 1 year ago #

    Hi,

    I just installed WP Multisite and follow the directions carefully but somethings gone wrong because after I create a new site it is not able to be found.

    First I did get an warning after creating multi site:

    Warning! Wildcard DNS may not be configured correctly!
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++
    The installer attempted to contact a random hostname (33c958.milkywaydigitalmedia.com) on your domain. This resulted in an error message: Couldn't resolve host '33c958.milkywaydigitalmedia.com'

    To use a subdomain configuration, you must have a wildcard entry in your DNS. This usually means adding a * hostname record pointing at your web server in your DNS configuration tool.

    You can still use your site but any subdomain you create may not be accessible. If you know your DNS is correct, ignore this message.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    I checked my subdomain configuration, it is set up as below:

    public_html/milkywaydigitalmedia.com - I used the "*" wildcard DNS

    Here is my .htaccess file:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    And my wp-config.php

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'milkywaydigitalmedia.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    My Site link is http://milkywaydigitalmedia.com/

    The thing that bothers me and I don't understand is in the warning that says "Couldn't resolve host '33c958.milkywaydigitalmedia.com'" . I don't know what the "33c958" is referring to:

    Any help or suggestions would be greatly appreciated!!
    Thanks

    Tim Millaway

  2. majestixx
    Member
    Posted 1 year ago #

    You are not seriously posting you db user and password in a public forum?

  3. majestixx
    Member
    Posted 1 year ago #

    Accordings to you problem: "33c958" is a random subdomain.
    as a ping to 33c958.milkywaydigitalmedia.com fails it seems that the wildcard dns entry does not work.

    What is a wildcard DNS? https://en.wikipedia.org/wiki/Wildcard_DNS_record

  4. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    timsaxm, please be more careful about not giving away info that hacker could use to compromise your site. You should really change your database password at least now it has been in the public domain.

    majestic, thanks for pointing this out, but you can alert a moderator to a topic that needs attention by adding a modlook tag to the topic

Topic Closed

This topic has been closed to new replies.

About this Topic