WordPress.org

Ready to get started?Download WordPress

Forums

After clicking on Comment Submit a 404 page comes up (7 posts)

  1. kenmac
    Member
    Posted 5 years ago #

    Hi - I'm using the theme 'inove' by mg12.

    When a visitor or myself as admin makes a comment and clicks on the Submit button a special 404 page comes up. The comment however IS posted.

    How can I stop this from happening please ?

    Thanks for your help.

    Ken

  2. rogerle
    Member
    Posted 4 years ago #

    Hi Ken.

    I'm also using the "inove" theme. I'm having the same problem, however, mine didn't appear until I upgraded to WP2.8 today.

    I noticed that my comment links are wrong
    http://siteurl/comment-page-1/#comment-18

    when it should be:

    http://siteurl/#comment-18

    It's adding that "comment-page-1" somewhere in wp-comments-post.php where the form is being submitted to.

    I've found it's appending it in the "get_comment_link()" function but that is as far as I've gotten so far.

    The comment is posted but it keeps directing me to a 404 because comment-page-1 or x doesn't exist.

  3. rogerle
    Member
    Posted 4 years ago #

    Kenmac,

    This helped me fix my problem.

    http://wordpress.org/support/topic/231504?replies=5

    I went into my Settings->Discussion

    and disabled my pagination for comments and then my comments started working correctly.

    I think this is more of a work around but It works. I'll have to come up with a more elegant solution should I have more than 50 comments per post.

    Hopefully this helps,

    Roger

  4. trentor
    Member
    Posted 4 years ago #

    Any resolution on this if you actually want to use the pagination option?

  5. idleberg
    Member
    Posted 4 years ago #

    disabling pagination does not fix this for me. all it does is giving me a blank page rather than a 404.

  6. m_vijayreddy
    Member
    Posted 4 years ago #

    I am facing the same problem when someone posts a comment, the page shows an error.

    I am using wordpress 2.9.1 version
    I dont see paging option in Settings->Discussion as i didnt install any plugin for comments

    help wud be greatly appreciate, thanks

  7. roberthq
    Member
    Posted 4 years ago #

    @rogerle
    that worked for me! Thanks for the tip! I don't have a lot of comments...so this was ok with me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.