WordPress.org

Ready to get started?Download WordPress

Forums

after change Permalink website not working proper (3 posts)

  1. bagra
    Member
    Posted 2 years ago #

    hi

    i m using wordpress 2.9.2 and i try to change Permalink /%postname%/ instead of defaults Permalink, but after did it website stop working properly and start showing 404 page cannot be found error

    any one have any suggestion or help ??

  2. You really want to consider upgrading from 2.9.2 as that's really old. But that's shouldn't cause your permalink problem.

    It's probably that mod_rewrite is not enabled in your Apache configuration or .htaccess is not getting saved.

    For pretty permalinks (the codex calls them pretty) to work that has to be enabled.

    http://codex.wordpress.org/Using_Permalinks#mod_rewrite:_.22Pretty_Permalinks.22

    For your directory you should have like

    <Directory />
       Options FollowSymLinks -Indexes
       AllowOverride All
    </Directory>

    That and enabling mod_rewrite should let your WordPress generated .htaccess file work.

    There are some servers that will permit that to be updated via the .htaccess file (don't copy this there) but I don't think that will work. Show this post to your host provider and maybe they can sort it out for you.

  3. prionkor
    Member
    Posted 2 years ago #

    Couple of things to point out.

    • Please upgrade the wordpress for gods sake! :)
    • Check that if webserver can write .htaccess files there. If it can you should see a .htaccess file on your root of wordpress installation.
    • Go and visit the permalink page again. That will flush the rewrites (if that is the problem this will solve immediately)
    • Last, before upgrading wordpress make sure you take backup and keep track of your widgets. Upgrading anything from blow 3.0 can cause loose of widgets

Topic Closed

This topic has been closed to new replies.

About this Topic