WordPress.org

Ready to get started?Download WordPress

Forums

Amazon Affiliate Link Localizer
Affiliate ID vs Tracking ID (11 posts)

  1. lutetia
    Member
    Posted 1 year ago #

    Hello,

    Before I use this plugin, I have two questions:

    1) For the Amazon US affiliate program, I use a "tracking ID" on my website, not my actual Amazon Affiliate ID, which is different (was originally generated based on a website I no longer have). Can I enter the "tracking ID" I normally use in the plugin settings instead of my official affiliate ID?

    2) If the answer to the first question is that I must use the actual Affiliate ID, not the tracking ID, do I need to replace the links I currently have on my site, or will the plugin change them from my tracking ID to my affiliate ID?

    Thank you

    http://wordpress.org/extend/plugins/amazon-affiliate-link-localizer/

  2. lutetia
    Member
    Posted 1 year ago #

    Update: I did a few tests, but could not get this plugin to work properly.

    I entered all the IDs I currently have (four countries). For the US program, I entered my official Affiliate ID. I also tried it using my website's specific tracking ID instead.

    Either way, the problem I'm having is that most of my links are not getting changed.

    I use US affiliate links on the website; since I'm not in the US, they should have been changed to show the ID for my country, but they remained as US affiliate links.

    The only exceptions are the four country links I have embedded as text-only links at the bottom of the page (US | UK | FR | CA). It did not change the links for any of my product links (image-only and product text links....) or banners.

  3. PeteWilliams
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I've not used tracking IDs myself but my understanding is that they're just aliases for your affiliate ID, so they should work in exactly the same way so just enter them in the settings.

  4. lutetia
    Member
    Posted 1 year ago #

    Thank you Pete, that seems logical to me.

    But I can't get the plugin to work.

    I am not using any caching plugins.

  5. PeteWilliams
    Member
    Plugin Author

    Posted 1 year ago #

    Can you post a link to a page on your site that has links on so I can have a look. It sounds like the problem could be you are using some kind of Amazon widgets rather than normal HTML links.

  6. lutetia
    Member
    Posted 1 year ago #

    There's a link in my profile.

    I know it won't work with widgets. I have some on inside pages.

    For example, it's not working on the book images in the middle sidebar.

  7. PeteWilliams
    Member
    Plugin Author

    Posted 1 year ago #

    OK, it looks like in this instance you have an unusual server configuration which is creating the following error:

    "Warning: get_headers(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /htdocs/www/wp-content/plugins/amazon-affiliate-link-localizer/ajax.php on line 104"

    So it looks like you'll need to set allow_url_fopen=1 in your php.ini

  8. lutetia
    Member
    Posted 1 year ago #

    Thank you, I'll try that.

  9. lutetia
    Member
    Posted 1 year ago #

    I found this at lines 869-871 of php.ini:

    ; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
    ; http://php.net/allow-url-fopen
    allow_url_fopen = Off

    and tried changing "Off" to"On", but made no difference.

  10. PeteWilliams
    Member
    Plugin Author

    Posted 1 year ago #

    Did you restart Apache?

  11. lutetia
    Member
    Posted 1 year ago #

    No, I didn't.

    I have no idea how I would do that.

    I will have to contact my hosting provider to see if they can help.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic