WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Excerpt
Advanced Excerpt not working (6 posts)

  1. babyewok
    Member
    Posted 3 years ago #

    I have installed the advanced excerpt plug in and it is not stripping the tags that I specify. However, it IS controlling the length of the excerpt that I specify on the module admin page.

    Why is it not stripping the tags?

  2. mariostella
    Member
    Posted 3 years ago #

    Same here. It has not stripped tags for me since version 0.x.x of the plugin. I used it with 2.9, now use it with 3.0.4. I updated it but it has the same issue. No tag stripping at all. I just need it to remove the paragraph tag, but it does not work even when <p> is the only selected tag.
    Everything else works fine. Such a pity, wish I could do it myself.
    Thanks for any help.

  3. Joy
    Member
    Posted 3 years ago #

    Um, you do realize that the label on the admin page says "Keep Markup"?
    So the tags that you check are the ones to keep.
    If you selected <p>, it will keep it.
    It works for me.

  4. mariostella
    Member
    Posted 3 years ago #

    Thanks for your reply Joy, I do realize that, and I did try all four ways to see if it was my bad or a problem with the plugin logic. So I checked the Keep markup and selected all tags, then unselected them all, then unchecked keep markup and done the same with the tags (all selected then unselected). All four instances did not bring about what I wantedm, and of course when all tags were allowed I would get all the html in the excerpt, making it a mess.

    So, the only thin NOT WORKING is the paragraph tag not being removed. If I have a paragraph in the content, no matter what, it stays in the excerpt, all other tags are removed.

    Hope this clarifies what workd and what not, and my understanding of the plugin.

    This plugin does not work for me as expected.

  5. ds123
    Member
    Posted 2 years ago #

    same thing for me its leaving the paragraph tag ... @mariostella did you find a solution or anyone?

  6. basvd
    Member
    Posted 2 years ago #

    Do I understand correctly that it's only <p> tags that are not removed?

    If so, then this is a duplicate (no worries, feedback is good).

    This bug will be fixed in the next update. I also posted a possible workaround in that other thread.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic