WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Admired Theme Date Display (5 posts)

  1. eknight74
    Member
    Posted 1 year ago #

    The Admired theme displays a snippet of posts on the homepage of my website. According to the theme information it is supposed to display the date of the post to the left of the post title in a small box. It sort of looks like a small calendar page.

    The theme is currently not doing this. I want to fix it so it will display in the manner described above but I don't know where to begin.

    Any help is appreciated. Thanks in advance.

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    there should be a theme option for this 'post calendar' output;

    you can see this when you look at the code of loop.php:

    if ( isset ($options['admired_remove_post_calendar']) &&  ($options['admired_remove_post_calendar']!="") )
    				{echo' ';}
    			else { ?>
    				<div class="calendar">
    					<span class="month"><?php the_time("M", get_option('date_format')); ?></span>
    					<span class="day"><?php the_time("d", get_option('date_format')); ?></span>
    				</div><!-- calendar --><?php
    			} ?>
  3. eknight74
    Member
    Posted 1 year ago #

    ok
    I found the above. What do I do to et it to work?
    How do I modify it?
    It is currently displaying the date under the title of the post.
    However, the theme is supposed to display it the way I am wanting to.

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    make sure you have the setting:

    admired theme options - general - Remove Post Calendar: OFF

    and save.

    be aware:
    the theme uses different loop-{post_format}.php templates of which only the standard post format seems to output the post date in calender form.
    sticky posts also do not show the calendar date.

    if adjusting the theme options does not help, edit loop.php, change this section:

    if ( isset ($options['admired_remove_post_calendar']) &&  ($options['admired_remove_post_calendar']!="") )
    				{echo' ';}
    			else { ?>
    				<div class="calendar">
    					<span class="month"><?php the_time("M", get_option('date_format')); ?></span>
    					<span class="day"><?php the_time("d", get_option('date_format')); ?></span>
    				</div><!-- calendar --><?php
    			} ?>

    to:

    ?>
    		<div class="calendar">
    			<span class="month"><?php the_time("M", get_option('date_format')); ?></span>
    			<span class="day"><?php the_time("d", get_option('date_format')); ?></span>
    		</div><!-- calendar -->
  5. eknight74
    Member
    Posted 1 year ago #

    ok
    From the very beginning I have had the post calendar option in the theme options turned off. That was the problem. When I installed the theme I thought that option turned off the full calendar in the sidebar. Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic