WordPress.org

Ready to get started?Download WordPress

Forums

Administrator no longer appears as post author (4 posts)

  1. tiszenkel
    Member
    Posted 7 years ago #

    So here's something odd. I, the administrator of my blog, can no longer be selected as an author on the Write Post page. Fun, huh? My blog currently has three authors, not including me, but none of them have ever posted anything. I can't even imagine what might have happened -- I didn't change any settings, not that I'd think it would be possible to lose an administrator as an author even if I had.

    I upgraded to 2.2 a few days ago, but I have posted since then with no trouble. The only other thing I can think of is that while the first author has been registered as an author for about a month, I just added the other two over this past weekend. One of them is a user I upgraded to author status; the other is a test account I created myself so I could see how that user viewed the control panel. I'm not sure if I've posted anything since I made those two users authors, but I don't believe I have.

    Ever heard of anything like this happening?

  2. tiszenkel
    Member
    Posted 7 years ago #

    I managed to fix this problem. If you're interested, here's how I did it:

    I created a new user with administrator rights. I logged in as that user and demoted my original account to subscriber status, then gave it administrator status again. Presto, it was back in the Post Author box. Finally, I logged back in under the old admin account and used it to delete the new admin account.

    I still have no idea why this might have been happening in the first place.

  3. MichaelH
    Member
    Posted 7 years ago #

    I believe it has something to do with the fact that when the orginal admin user was created, the wp_user_level value in wp_usermeta wasn't created for that user. Subsequent changes of roles caused that record to be created. Your solution is probably the easiest workaround for the problem.

    Can you remember what Version you originally installed when you started using WordPress?

  4. tiszenkel
    Member
    Posted 7 years ago #

    Yep, it was the version immediately preceding the current one -- 2.1.3, I believe.

Topic Closed

This topic has been closed to new replies.

About this Topic