WordPress.org

Ready to get started?Download WordPress

Forums

Adminimize died - Invalid argument supplied for foreach() (2 posts)

  1. windyjon2
    Member
    Posted 5 years ago #

    Hi,

    Any help would be greatly appreciated.

    I upgraded from 2.7 to 2.7.1 and adminimize just stopped working. When activated I get the following error message:
    Warning: Invalid argument supplied for foreach() in path/wp-content/plugins/adminimize/adminimize.php on line 58

    Warning: Invalid argument supplied for foreach() in path/wp-content/plugins/adminimize/adminimize.php on line 58

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in path/wp-content/plugins/adminimize/adminimize.php on line 738
    followed by a long list on (in-array0 errors
    etc, etc

    I've tried removing the plugin, and upgrading to the new one. But get the same error. Its not possible to access the Adminimize settings screen.

    There isn't a separate adminimize table in the dbase, or I would try deleting that.

    Any ideas of what I could do would be greatly appreciated. I just don't know what to try now.

    Many thanks in advance.

    Jon

  2. windyjon2
    Member
    Posted 5 years ago #

    OK, getting somewhere.

    I installed an older version 1.6.5.
    Then managed to access Adminimize / deinstall options.

    Then deleted the old files and reinstalled 1.6.7.
    It all seems to work fine.

    Basically it needed to be deinstalled properly from the dbase, something I couldn't do with the existing version. And I didn't know which dbase entries to modify.

    Seems to have fixed it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags