WordPress.org

Ready to get started?Download WordPress

Forums

Admin VERY slow since 3.1 (43 posts)

  1. takezo.akira
    Member
    Posted 3 years ago #

    I've done an auto-update from 3.0.5 to 3.1, everything was right.

    I have several blogs on the same WP instance (multiblog), everything is fine (and fast) on the FRONT. The blogs are OK.
    But the BACK (admin) is VERY slow, like 2 min to open a page...!

    I have no idea...so i had to go backl to 3.0.5 :-(

    Anybody having the same problem ?

    I have this extensions:
    AddToAny Version .9.9.7.4
    Akismet Version 2.4.0
    Postcasa Shortcode Version 1.0
    Google Analytics for WordPress Version 4.0.9
    jQuery Colorbox Version 1.0
    Viper's Video Quicktags Version 6.3.0
    WP-Syntax Version 0.9.9

  2. Rachel Carden
    Member
    Posted 3 years ago #

    I'm having the same problem. I, too, have a multisite. None of my plugins are activated. Since I only use a few, I'm even going through and deleting them and it doesn't seem to be having an effect so I don't think it's a plugin issue.

    Perhaps a multisite issue?

  3. coffeehero
    Member
    Posted 3 years ago #

    Yes. My extensions are different, but I have found the new LINK option is painfully slow. I'd love to roll back just that feature.

  4. Ian
    Member
    Posted 3 years ago #

    I miss how the links used to autocomplete based on previews things for that field. I don't need the in-site linking as much as I need that. If anyone knows how to do a rollback, I'd like to know.

    In general, everything is going slow for me since the 3.1 upgrade. Front an back.

  5. takezo.akira
    Member
    Posted 3 years ago #

    coffeehero - Yes. My extensions are different, but I have found the new LINK option is painfully slow. I'd love to roll back just that feature.

    Do you think the admin is very slow because of this NEW link option ?

  6. takezo.akira
    Member
    Posted 3 years ago #

    Still have the problem. :-(
    I've made a new upgrade, everything was fine, no error messages during the process.

    The blogs works pretty well, but the admin is VERY VERY slow...
    I've put all the plugins off. Still the same problem !

  7. Ian
    Member
    Posted 3 years ago #

    very weird. Do you have any custom code in your functions.php? Sometimes I find things in there can mess me up.

  8. takezo.akira
    Member
    Posted 3 years ago #

    OK i just find the solution !
    I've removed the admin bar for the admin and everything is fine.

    I'm in Worpress multiblog. For the super-admin the admin bar make the back very slow. For a "normal user" tha bar works well.

  9. Ian
    Member
    Posted 3 years ago #

    ah! I'm sorry I didn't think of that. The very first thing I did was put the code in the functions php to disable it for all users (it conflicted with sidebar login stuff I'd already put in and css styling.)

    Glad you figured it out!

  10. ianaleksander - Devs are aware of the autocomplete issue and are looking into that.

    takezo.akira - Dump your browser cache and let it re-build. Once you've cached some stuff, it SHOULD speed up a bit.

  11. Ian
    Member
    Posted 3 years ago #

    great, good to hear! Thanks!

  12. takezo.akira
    Member
    Posted 3 years ago #

    OK for everybody who have a very slow admin after upgrading to 3.1, in a multiblog site, here is a solution : remove the admin bar for the super-admin.
    For some reasons the admin bar works well for a basic users but when activated for the super-admin the backend is VERY slow.

    Hope it can help somebody...

    I think it's related to a proxy problem. Cause i'm behind a proxy.
    Maybe the admin bar for the super-admin is trying to connect somewhere (without proper proxy settings) ?
    And for a basic user it does not try to connect.

  13. It shouldn't be pinging anywhere though ... It DOES get a list of your sites on MultiSite, and I can envision that slowing down things if you have a lot of sites.

  14. takezo.akira
    Member
    Posted 3 years ago #

    It's because of the NAT.
    Somebody tell me that the admin bar is pinging itself.

    I'm not expert but it's about that :
    http://codex.wordpress.org/User:Westi/Hosting_WordPress_Behind_NAT

  15. chattan
    Member
    Posted 3 years ago #

    I tried removing the admin bar from my profile, but after a 5 minute wait, the profile page re-appeared with the check boxes re-checked after I'd unchecked them! Is there another way of getting rid of the bar?

  16. simplyDelicio.us
    Member
    Posted 3 years ago #

    this latency is killing me.......where and how do we remove that admin bar? just saying "remove the admin bar" doesn't explain "how?" we're not behind a nat, and this problem only cropped up after the 3.1 "upgrade".....usually the word "upgrade" is suppose to mean better, but with wordpress it always seems to be "hey let's beta test this on people in the real world who'll give us some REAL feedback!! here's the feedback: 3.1 sucks if you have a multisite (unless you actually enjoy 3-5 minute waits on your your edit updates) .....can you say "let's go grab some coffee and maybe when we get back the edit will be updated, unless it goes 501 once again!!

  17. simplyDelicio.us
    Member
    Posted 3 years ago #

    i guess it would have helped to read the post just above my rant where chattan said "I tried removing the admin bar from my profile" (keywords here are USER PROFILE), but sometimes i get so annoyed with wordpress (dare i say i would ever use any other besides them), and i just had to vent after losing my entire morning to dealing with this headache.....oh, and by the way, removing that useless admin bar did the trick, and i can actually once again see edit changes occur right before my very eyes......go figure

  18. Ian
    Member
    Posted 3 years ago #

    you can disable it sitewide by putting this small code in your functions.php

    /* Disable the Admin Bar. */
    add_filter( 'show_admin_bar', '__return_false' );

  19. chattan
    Member
    Posted 3 years ago #

    I tried putting ianaleksander's code at the beginning of functions.php but couldn't then login. Wrong module? Wrong place?

    I reverted to updating my user profile and this time I was able to uncheck both admin bar options and save changes. No effect on delay times though, still 5+ minutes.

    Tried doing some network admin: went to update network, waited ages, said it had completed ok but message wouldn't disappear from top line.

    Tried looking at my sites: dashboard said 15, but when I clicked on my sites, it reckoned I didn't have any.

    So, slow as death and no sites any more. Am I officially dead?

  20. simplyDelicio.us
    Member
    Posted 3 years ago #

    hopefully the guys at wordpress will soon realize the err of this monumental mistake and post up another update.....the admin bar serves no good purpose whatsoever and only causes heartache and problems

  21. chattan
    Member
    Posted 3 years ago #

    That was a rhetorical question. I think I'm alive.

    Decided to run upgrade.php which was cathartic. Response times now as fast as shit from a shovel.

    Some warning shots about accessing one of my multi-sites, but it's there ok and the protests stopped after log off/on. Network update message has vanished also.

    May have to revert to real work tomorrow. Long day today...

  22. Ian
    Member
    Posted 3 years ago #

    is that slow or fast? I can't tell with the metaphor, haha.

    Sorry that code didn't work for you, it's pasted directly from my functions - don't know where I originally found it.

  23. chattan
    Member
    Posted 3 years ago #

    That is fast, but local variations in ordure and implement could introduce a wide observation range.

    Don't worry about the code. Now that I've got a workround from settings changes, it's cleaner to avoid patching and wait for a fix release which I hope will tidy things up properly.

  24. justshopandgive
    Member
    Posted 3 years ago #

    I'm still having this issue despite having disabled the admin bar.
    I don't beleive it's a plugin problem as I have an exact copy locally of the site and it's running fine - so perhaps I have a connection/site host issue?

    I am unable to access my posts at all via the normal route (just hangs though I haven't just left it to see if it finally works) but can sometimes get to them by clicking categories from the dashboard and then clicking the number next to the category I want to edit.
    I have 113 posts which I don't think is that many!?
    Similarly with Pages of which I only have 13.

    This is making the site uneditable.
    I don't think it's an issue with my host, as I have other sites with them and do not have the issue, although they are on different boxes.
    I seem to be going round in circles trying to figure out what is going on.
    Anyone else still having a problem after disabling the admin bar?

  25. chattan
    Member
    Posted 3 years ago #

    As above, my site was still slow after disabling the admin bar, but running upgrade.php fired things into life (I think it synched my database with 3.1). Try yourdomain/wp-admin/upgrade.php in your browser bar.

  26. er8306
    Member
    Posted 3 years ago #

    I tried what chattan mentioned and my multisite installs also sped back up.

  27. justshopandgive
    Member
    Posted 3 years ago #

    I have tried the yourdomain/wp-admin/upgrade.php suggestion but I simply get a message saying no upgrade required and it's still very slow.
    Clicking on Pages from the dashboard takes about 30 seconds to access and Posts is taking 3 minutes+.
    Other wordpress installations (same version) I have on different servers are also fine - its just this one site.
    Finally the admin of the site is fast and accessible through a different broadband provider which makes me think it's my ISP. But why would it be just for this one site?
    I am truly confused but will keep trying to find a solution.

  28. Publisher100
    Member
    Posted 3 years ago #

    I've noticed this problem too. Along with the slowdown, I noticed a sharp increase in spam emails entering the queue. My initial reaction/thought was that somehow I had a security compromise. I reached the point that essentially I gutted the system, took out all the wordpress code and files (after exporting the content), and then rebuilding from scratch.

    Problem remains. Things run at a snail's pace. I haven't been able to test on other servers but have used different operating systems. The standard "plugins must be bad" argument doesn't hold water as the site is now quite stripped down with very few plugins.

    The system is slowest, however, on plugin and theme admin. It is faster in updating posts.

    I'm obviously now using the most current versions of WP on a cleaned-up server. But it is slow . . . far too slow . . .

  29. Publisher100
    Member
    Posted 3 years ago #

    WordPress.com has been experiencing a major ddos attack this weekend. While this shouldn't theoretically affect wordpress.org, the akismet.com spam control service is operated out of wordpress.com, so maybe there is some linkage here.

    it is a mystery, nonetheless.

  30. Willy2003
    Member
    Posted 3 years ago #

    Painfully slow, sticky like shit in grey hair :-(

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags