WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Admin tool deleted (13 posts)

  1. maggiecurran
    Member
    Posted 7 years ago #

    Yes, I stupidly deleted a file from my server /www/wp-admin because there was another similarly named file under /www/wordpress/. I was deleting duplicate files because everytime someone comes to my blog they are asked for a username and password. I deactivated the moderation authorization-related functions, but I noticed that the themes had been uploaded twice under two different directories. This led me to going delete-happy.

    What can I do? I am unable to access the admin panel at all. I get a THIS PAGE NOT AVAILABLE message, when I try.

    I still have the login problem to boot...

    Am calmly sipping wine, hoping someone will help me before I start to pull my hair out...

  2. whooami
    Member
    Posted 7 years ago #

    how bout re-uploading whatever you deleted (wp-admin/index.php I am guessing)? Seems sort of like the obvious solution to me.

  3. maggiecurran
    Member
    Posted 7 years ago #

    I've tried that. Doesn't work.

  4. whooami
    Member
    Posted 7 years ago #

    doesnt work for what? for the problem in THIS thread, or some other thread?

    and if I can be so bold as to make a suggestion.. your tags for this post: what exactly does the tag "stupid" add to the forum? The tags are supposed to be used for helping the searchability of the site -- certainly "stupid" isnt really a useful tag, dont you think? For that matter, "mistake" doesnt add much either.

  5. maggiecurran
    Member
    Posted 7 years ago #

    deleted stupid. feel better? yeesh. people are so pedantic here. i don't get why.

    i just need help with a problem. i tried what you suggested for the problem in this thread, for which you made the suggestion in the first place.

  6. whooami
    Member
    Posted 7 years ago #

    If by pedantic, you mean finicky, yes i have to say people are. After all, there are .. 40,420 (and counting) topics to the troubleshooting area. God forbid there be any kind of common-sense applied to the usability/searchability of those topics.

    If by pedantic you mean "overly concerned with formal rules" see paragraph 1.

    As for your initial problem:

    IF you deleted files, and after that you started experiencing a new problem, then you need to reupload ALL of the files you previously deleted.

    How bout you provide some more information:

    1. what files you have deleted.
    2. what files you have re-uploaded
    3. Exactly what page on your site you are attempting to access where you see an error.
    4. whether or not you are using wp-cache.

  7. maggiecurran
    Member
    Posted 7 years ago #

    1. I deleted all the wordpress files that existed in the /www directory. My actual WordPress files are all located in /www/wordpress/. The files were wp-admin ( i think it was a folder)

    2. i uploaded all the WordPress 2.0.4 files into the /www/wordpress directory. When that didn't work, I uploaded to the /www directory a wp-admin file (but I see it says wp admin.css .

    3. When I go to the homepage of my blog (www.mylifeinstockholm.com) i get a box asking me for username and password.

    4. i don't know what wp-cache is.

    Thanks for asking questions I can understand and answer. Sometimes some people forget that not all of us are so deeply into this stuff, even though we might have to use it.

  8. whooami
    Member
    Posted 7 years ago #

    im prolly as confused as you are, Im sorry.

    I am unable to access the admin panel at all. I get a THIS PAGE NOT AVAILABLE message, when I try.

    Are you having trouble still with your admin directory or has that been resolved by you re-uploading files?

    The login message you're continuing to see, to me atleast, still looks like a case of you password protecting a directory on your site. Go into your cpanel/plesk/what have you and hunt around to see if you have password protected ANY directories, and if so, undo that.

  9. maggiecurran
    Member
    Posted 7 years ago #

    i can't access the control panel at all. that's what i'm talking about. that's what i mean when i write "admin tool" --- i have no control panel. i cannot add posts, edit, etc. i can't even login. there's nothing there.

    i didn't resolve my admin panel/control panel problem and i created a new one by deleting files. i have uploaded everything more than twice. don't know what to do.

  10. whooami
    Member
    Posted 7 years ago #

    no. no. not your wordpress admin area. When I say "control panel" I mean cpanel, plesk, the area your host set up for you to administer your entire domain.

    We're gonna need to deal with one problem at a time, and Im not going to be much help much longer as I have to leave for work.. so hopefully someone else can pipe in after Ive stopped replying (its not that i decided I dont want to help, its that ill be stuck in traffic)

  11. maggiecurran
    Member
    Posted 7 years ago #

    I checked the control panel in the webhost. There were no password protected files. I then tried to login to WordPress Admin Tool from the webhost and I got this error message:

    Fatal error: Cannot redeclare user_can_create_post() (previously declared in /data/members/paid/m/y/mylifeinstockholm.com/htdocs/www/wordpress/wp-includes/functions-post.php:335) in /data/members/paid/m/y/mylifeinstockholm.com/htdocs/www/wordpress/wp-includes/capabilities.php on line 356

  12. maggiecurran
    Member
    Posted 7 years ago #

    I've checked the wp-includes.php file, which supposedly has an error on line 335 (i've never touched this file, so i don't know what's going on), and these lines are involved:

    329. $pattern = "#$word#i";
    330. if ( preg_match($pattern, $author ) ) return true;
    331. if ( preg_match($pattern, $email ) ) return true;
    332. if ( preg_match($pattern, $url ) ) return true;
    333. if ( preg_match($pattern, $comment ) ) return true;
    334. if ( preg_match($pattern, $user_ip ) ) return true;
    335. if ( preg_match($pattern, $user_agent) ) return true;
    336. }

    There is also an error in another file. I'm going to go through it now and find the line.

  13. maggiecurran
    Member
    Posted 7 years ago #

    Ok, i'm seeing that the errors in the php files are syntax errors - i'm not sure what else to call them. i have fixed the obvious ones (i didn't make these changes btw). here is one that i don't know how to fix, since it needs a DO ACTION part to it - i'm referring to the "stripslashes" section of this code:

    do_action('plugins_loaded');
    --------------------------------this is the part i need help on (there is no action defined):

    // If already slashed, strip.
    if ( get_magic_quotes_gpc() ) {
    $_GET = stripslashes_deep($_GET );
    $_POST = stripslashes_deep($_POST );
    $_COOKIE = stripslashes_deep($_COOKIE);
    }
    ----------------------------------------------------
    // Escape with wpdb.
    $_GET = add_magic_quotes($_GET );
    $_POST = add_magic_quotes($_POST );
    $_COOKIE = add_magic_quotes($_COOKIE);
    $_SERVER = add_magic_quotes($_SERVER);

    do_action('sanitize_comment_cookies');

    Can anyone help??? thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic