WordPress.org

Ready to get started?Download WordPress

Forums

Admin sometimes 404, links mainly 404, site normal (12 posts)

  1. Claverhouse
    Member
    Posted 4 years ago #

    I looked at all the other 2.9.2 + Admin + 404 threads --- there are a lot but none replicating my exact problem.

    After upgrading automatically some time ago everything was as usual working excellently, as it has for 3 years, then after a post on the 22nd March, I suddenly got 500 pages for both the site and the Admin.

    So... I'll copy directly from my blog to explain:

    A week or so before I had emplaced a new improved .htaccess, as described here and here, it worked well and seemed to increase speed — so I’m absolutely certain this had nothing to do with the later problems. When on the 22nd I could not enter the site due to the 500 pages, I began flashing new trial .htaccess’s in and out as if confetti and updating the settings on the Dreamhost Web Panel ( ‘Edit Site’, simply updating without altering settings ) which restored it to semi-normality; although I was getting Dreamhost 404s whenever the .htaccess was improper. I was then able to uninstall supercache in the recommended way, and for good measure through ftp deleted all recent plugins. This now came back to serene falcon-specific 404s. Which I still get if the browser is busy, yet if undelayed the admin panel shows. From here any linked page or url shown in that panel sometimes works, but usually resolves into a 404. Should I hit the Update Permalinks button — which is mandated after any change — the whole thing starts over and requires the previous Dreamhost Settings to be hit again.

    Whenever I hit Update Permalinks I get a site-404, but it may have gone through, as when I hit Save Draft it also goes to 404 but I later find from the Admin Panel it was saved. Dreamhost has been a tower of weakness in helping with this ( it might be server-exacerbated, it's an old server ).

    The present position is that the site comes up fine; posts opened as pages sometimes come up fine and sometimes as 404s: the Admin Panel comes up 2 out of 3 as a 404 --- particularly if the connection takes a time --- but then I get lucky and see either it complete or semi-complete ( but fully loaded according to Firefox, just without all sections ). Links like Plugins or Firestats generally are 404s, but none of the statistics actually work.

    The present .htaccess is the standard:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    And I have to save the Dreamhost Site Settings from their Web Panel and hit the Update Permalinks button to clear things when the Admin Panel won't come at all. I'm supposing that something in 2.9.1 and .2 has affected a lot of sites with 404s and Permalink problems...

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

  3. Claverhouse
    Member
    Posted 4 years ago #

    I've deactivated all the plugins several times... Including renaming the folder etc.. Nothing. Plus as said I took out all recently updated plugins and uninstalled supercache.

    And no,I've had the same theme for the past three years with no alteration or addition, so that is very unlikely.

    My best bet is that the slight fault I intimated in my last sentence is mixing badly with an old server: leaving a piece of blame on each side. And that the Permalink updating issue is at the heart of the problem.

    [ I have always used /%postname%/ since the start. Altering to default and then back --- or to other structures --- makes no difference. ]

  4. Beer
    Member
    Posted 4 years ago #

    I'm having this problem with a few wordpress sites on Dreamhost now. It just appeared, where it had been fine for years.

    I'm getting the occasional 404 errors especially in the Dashboard (wp-admin), and I can just refresh the browser and get the page as it should have been displayed.

  5. Beer
    Member
    Posted 4 years ago #

    A temporary but interesting update.

    In my log files I'm seeing "Premature end of script headers", and Dreamhost has responded that their process watch is killing these for exceeding my allowed RAM usage.

    2010-05-15 14:15:59 procwatch2 INFO: Process(pid=2732, name='php5.cgi',
    uid=user(138570), tty=None, cpu=3.0, rss=12656.0, vsize=66324.0): kill
    for total RAM

  6. You could have a plugin that's causing that. Try deactivating all of the plugins. If that resolves the issue, reactivate each one individually until you find the cause. If you can't access the admin panel to deactivate the plugins, follow this guide:

    http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    See my original response above.

  8. Beer
    Member
    Posted 4 years ago #

    macmanx, I had already removed all plugins and moved one at a time over. In my situation, the total RAM used by my user with Dreamhost exceeds whatever they've defined it as on this particular server. The plugin removal didn't help.

    memory_get_peak_usage() reports 30M for my wp 2.9.2 + theme + plugins.

    esmi, see above. The basic theme, and no plugins of course was leaner. I'd rather upgrade and keep the theme + plugins (akismet, stats, yarpp, all in one seo) I've been used to running with the same host for 3+ years. I didn't start to experience an issue until they moved me to a newer server.

    My previous reply in this topic was to help provide another answer for the 500 Internal Server Error that some are getting. It may be a similar situation, where the host has an automatic process watch that is killing the process.

  9. In that case, you may want to ask them to move you back to the old server, or consider switching to a new hosting provider. For example, A Small Orange (my host for over five years) does not have an automated process that kills scripts for exceeding RAM usage. They do have a 32MB limit, which you can easily get around with a few adjustments either to wp-config.php or .htaccess, and they do get rather upset if you constantly abuse this privilege, but there's no automated script killer like the one at Dreamhost.

  10. Beer
    Member
    Posted 4 years ago #

    I enabled each of my plugins one by one for reference. Next to each is the amount of memory used after enabling each plugin in sequence.

    WordPress w/o plugins - 15M (15835096)

    Akismet - 16M (16276944)
    All In One SEO - 17M (17318744)
    Auto Tags - 17M (17373960)
    Dashboard Post It - 17M (17394792)
    Google XML Sitemaps - 17M (17494376)
    Wordpress Stats - 17M (17866848)
    WP DBManager - 18M (18111904)
    WP Super Cache - 19M (19834088)
    TDO Mini Forms - 29M (29250128)
    Lightbox Plus - 29M (29547240)
    Sociable - 30M (30035536)
    WP FLV - 30M (30086768)

    WP Dashboard - 33M (33632264)

  11. freesoftwarepc
    Member
    Posted 3 years ago #

    i have same problem http://freesoftwarepc.biz/wp-admin/
    404 Not Found

  12. Rhand
    Member
    Posted 3 years ago #

    Similar issue too and I cannot really live without the plugins used. AND I think it should not be too much of a memory hog to use all these. Just wonder if the Shopp plugin is the final drop triggering the Dreamhost's procwatch script that kills the loading of pages.

Topic Closed

This topic has been closed to new replies.

About this Topic