WordPress.org

Ready to get started?Download WordPress

Forums

Admin site responds, but main page is inaccessible (4 posts)

  1. dfliddle
    Member
    Posted 5 years ago #

    This morning, two sites that I manage on the same host (1&1.com) were working fine, and I made no major change. This afternoon, I can't access the home pages of either (fpcd.org and liddles.net), but I can access the admin pages without a problem. Individual posts and regular pages also respond.

    What other information do I need to provide to resolve my problem?

  2. scribblerguy
    Member
    Posted 5 years ago #

    I was getting the endless wait for liddles.net, but could get to a specific page (e.g., liddles.net/?p=3), but now I get this:

    Error 500 - Internal server error

    An internal server error has occured!
    Please try again later.

    Though, that was only for a moment. Now, it's back to the non-resolving loop.

    The "500" error suggests that there's an error in one of the configuration files that Apache (the software on your web host's server that actually "serves up" the web pages). Though it could be related to the PHP processor.

    Since this is happening on two domains, this seems more likely to be a pure server configuration issue, but you'll need to some testing first, to make sure.

    The first place to check for Apache configuration files is the root of your domain. I see that on liddles.net, you're use pretty permalinks, so WP should have generated a .htaccess file in the root (or, if you installed WP in a subdirectory, in that directory).

    Rename the .htaccess file to something and try accessing your domain. If the problem stops, then the issue is probably some setting that is contained in that .htaccess file.

    If that stops the issue, go back to the Permalink settings page in the Admin Panels and update the permalink structure so that WP can regenerate its .htaccess file. If you don't do this, WP will continue to use pretty permalinks, but the Apache web server won't know how to process those requests.

    If none of the above fixes the problem, then turn pretty permalinks off and switch to a default theme and deactivate all plugins. If the problem still occurs, then we can likely rule out something that WP or a plugin is doing.

    Then, this is probably an issue related to your webhost's server configuration (maybe they just upgraded something), and you should ask your host's support for help in further isolating the problem. But, you need to do the above things, first.

    EDIT: I was able to get http://www.liddles.net/index.php to come up, but it seemed to take thirty seconds at least, but since I had that going in a background tab, I wasn't paying attention.

  3. dfliddle
    Member
    Posted 5 years ago #

    The site returned after I turned off the pretty permalinks, switched to the classic theme, and turned off all of the plugins. I'll now try to return things, one by one, to see what breaks it.

  4. dfliddle
    Member
    Posted 5 years ago #

    *** SOLVED ***

    The culprit was a feature of the "Holy Scripturizer" plugin that creates a "Show/Hide" link within the post, after the reference, which can display the passage within the text of the post. After disabling only that feature, the page loads as expected.

    Thank you very much for your help, Scribblerguy! The ease of administering WordPress made recovery a breeze, and I appreciate the simplicity of the software.

Topic Closed

This topic has been closed to new replies.

About this Topic