WordPress.org

Ready to get started?Download WordPress

Forums

Admin redirect not redirecting ... (6 posts)

  1. gvibe06
    Member
    Posted 7 years ago #

    So .. I got my wordpress all nice and started. Worked on my theme all weekend. Started a couple of topics. Logged out and went to bed.

    Since yesterday, I have not been able to log into my admin account. So I searched these forums and found a couple of steps to try and remedy this login problem.I've changed my password using PhpMyAdmin and I've tried copying over the wp-* files from the source archive. Nothing has worked so far.

    My site "DOES" recognize my account information, I know this because when enter incorrect info I see the RED Wrong Password message. But when I enter the correct info and press 'submit' - the page refreshes and I see this in my URL Address bar:

    [code]http://localhost/wp-login.php?redirect_to=%2Fwp-admin%2F[/code]

    Someone please help meh :/

    gVibe

  2. spencerp
    Member
    Posted 7 years ago #

    Well, as far as I know.. you seeing this in the URL:
    http://localhost/wp-login.php?redirect_to=%2Fwp-admin%2F

    is right..but, once logged in, it should then be:
    http://localhost/wp-admin/

    Did you try clearing your browser cache, also..do you have a WordPress cache plugin running? Have a cache folder made inside the wp-content/ directory.. if so..maybe try clearing that folder.. and clearing the browser's cache: CTRL + F5 once..

    spencerp

  3. gvibe06
    Member
    Posted 7 years ago #

    Tried them all. Cache dir does not exist and cookies have been cleared. The redirect just doesn't happen, and when I try forcing the url to localhost/wp-admin/ it goes back to that url I mentioned in my original post -> over and over and over.

    Additionally, I have tried 3 different browsers, 4 different computers from different locations. All produce the same results.

    Could this be caused by the way Apache handles redirects? If so, where in the WordPress setup can this be changed? Or will I have to recompile apache again?

  4. spencerp
    Member
    Posted 7 years ago #

    Which version of WordPress are you using on the Localhost? If you're using one of the Alphas.. I kinda remember of one, that had a similar problem.. but, of course..as the devs got word of it.. and submitted new fixed files to the SVN, I just grabbed them, and used them... and problem went away..

    Also, are you using Xampp Lite, or something else?

    spencerp

  5. frankj
    Blocked
    Posted 7 years ago #

    Hi

    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

  6. relaxedguy
    Member
    Posted 7 years ago #

    I get the same problem, but am able to log in with Safari on Mac, it doesn't work with Firefox. Cleared all caches, restart browser, etc. Perplexing problem! Another 2 hours spent on WordPress problems.

Topic Closed

This topic has been closed to new replies.

About this Topic