WordPress.org

Ready to get started?Download WordPress

Forums

Admin problems (8 posts)

  1. fbendz
    Member
    Posted 7 years ago #

    Hello! I have two problems with the admin role in my blog. To save space I post them as one question. I hope that is OK.

    Background:
    I've installed WordPress 2.0.4 using Fantastico on a Cpanel account and then upgraded to 2.0.5 using the instructions provided on WordPress.org. I did not use the name "Admin" for the administrator but rather used another login name to make it more difficult for hackers.

    First problem:
    I found that the admin name did not display properly. I checked in the MySQL database and found that the admin displayname was set to <ADMINNICENAME>. I changed it to Admin, which I felt was safe due to the Admin having another login name. I searched the php pages and did not find a match for <ADMINNICENAME>. What may have caused this problem? Is it a bug in WP or did Fantastico set that name?

    Second problem:
    I'm using the function wp_list_authors to display authors in the sidemenu:

    wp_list_authors('sort_column=name&optioncount=1&hierarchical=0');

    This works fine for all authors but the admin, who's name is not displayed at all. It just says >> (2) when it should say >> Admin (2). (Remember that the display name for admin is "Admin" and that I'm using another login name.

    I thought I located the bug in the function list_authors where one line reads (in part):

    ($exclude_admin ? "WHERE user_login <> 'admin' " : '')

    Since my admin's user_login is NOT "admin" I figured that was why it just displayed blank, but when I changed it to the correct name and uploaded the php file (template-function-authors.php) it still displays blank. Any idea why?

    I could not find any posts regarding any of these problems when I searched the support database.

  2. fbendz
    Member
    Posted 7 years ago #

    I solved the second issue myself. 'hierarchical' is not a parameter for the function in question. Removing the parameter removed the administrator from the listing. The first issue is still unresolved.

  3. jackosh
    Member
    Posted 7 years ago #

    1) never change anything in the database.. ever.
    2)wp_list_authors('sort_column=name&optioncount=1&hierarchical=0&exclude_admin=0');

    you need to include the "exclude_admin" attribute, because wp sets this to 1 (true) by default. Again, there is no "bug".

  4. fbendz
    Member
    Posted 7 years ago #

    I did not quite solve the second issue actually. When I add "&exclude_admin=0" to the function, it once again displays as no name with 2 posts.

  5. fbendz
    Member
    Posted 7 years ago #

    jackosh, why does the admin display as having no name?

  6. jackosh
    Member
    Posted 7 years ago #

    consider logging in ad the admin account and clicking "users". try the drop-down menu that says "display name publicly as: XXXXX".

    again, never change anything in the DB. if there was a "bug" that big, you wouldn't be the only person experiencing problems with it, and it would be fixed by now.

  7. jackosh
    Member
    Posted 7 years ago #

    PS you should revert the DB back to the way it was before you changed things around.

  8. fbendz
    Member
    Posted 7 years ago #

    OK, I changed it back to <ADMINNICENAME>, set the nickname to Admin and now the name shown in the list is Admin. However, the link in the sidemenu is to a non-existing archive page /authors/<ADMINNICENAME>. I guess this topic is covered in another post. How do I fix it?

Topic Closed

This topic has been closed to new replies.

About this Topic