WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] admin posts as most recent user... (8 posts)

  1. everydayhero
    Member
    Posted 6 years ago #

    For some reason while I am under admin and post, the post is listed like it has been posted from the latest registered user. The post thinks the latest registered user is its author. If you go to my site http://milliondollarblogger.net you'll notice a few posts. each one was posted by myself under admin, but under different authors. How do i fix this? I want to post as the admin!

    Another problem is that after I accidentially post as the other user, I cant delete the post from either the admin, or the users account! It gives me a "You don't have permission to do that." message.

    Any ideas on what I could do to fix this? or what files control this type of behavior? (I have already extensively edited many files, so it may be something I have incurred...)

    Thank you for your help!

  2. everydayhero
    Member
    Posted 6 years ago #

    anyone?

  3. everydayhero
    Member
    Posted 6 years ago #

    sorry to bump again... i just need an idea of what to play with to fix it...

  4. MichaelH
    Member
    Posted 6 years ago #

    Please understand bumping is poor form and aggravates the people who might be inclined to answer your question.

  5. MichaelH
    Member
    Posted 6 years ago #

    Check your theme. Make sure you are properly using the the author template tag if that is how you are displaying the author.

    Please also review:
    Stepping into Templates
    Template Hierarchy

  6. everydayhero
    Member
    Posted 6 years ago #

    oh i understand completely, but without a bump, or another way to communicate with other members, or performing even worse form and duplicating the post, the question will get lost forever in a sea of confused wordpress users. at least by bumping, the question might get answered, and may help someone else in the future so that they dont have to repost the question and get yelled at as well.

    As always, any help would still be appreciated, sorry for the poor form. If anyone has any ideas to make the support forum better, so that this stuff doesnt need to keep happening, please bring it up.

  7. moshu
    Member
    Posted 6 years ago #

    the question will get lost forever in a sea of ...

    Wrong assumption. Most helpers go first to the unanswered topics view, and start answering them.
    The nice thing is: by bumping it you remove your post from there, so it looks like having 3 answers, LOL - I think that's a divine punishment ;)

  8. everydayhero
    Member
    Posted 6 years ago #

    ok, I ended up using http://trac.wordpress.org/ticket/3807 like everybody else that had the same problems. It solved both of the problems I was having.

    It didn't work before, because I had edited my old pluggable.php to pieces, so I had to download a new one.

    Unfortunately, I don't remember why I had to edit pluggable.php in the first place, so when errors start popping up, ill know where to look :P

Topic Closed

This topic has been closed to new replies.

About this Topic