WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Admin Permalink settings show up wrong (8 posts)

  1. inge12
    Member
    Posted 2 years ago #

    After running a test site in a sub-directory of another domain, I successfully moved the site into the root in order to run multi-site.
    Then I (finally) successfully moved this test installation to the real domain.

    After much frustration, it seems that everything is finally working, except for one thing: The Permalink structure shows up incorrectly on the Admin page of the main blog. The main blog sits in the root directory, and actual permalinks (/%postname%/) are rendered correctly on the site. Permalinks of sub-sites are also rendered correctly.

    However, on the Admin page for Permalink structure, this is what I get:
    `Default http://ssnet.org/?p=123
    Day and name http://ssnet.org/blog/2011/06/02/sample-post/
    Month and name http://ssnet.org/blog/2011/06/sample-post/
    Numeric http://ssnet.org/blog/archives/123
    Custom Structure /blog /%postname%/`
    I have tried to find that elusive "blog" word in all sorts of places, including the whole databse. (I got experience editing it manually in this move!) However, I cannot find it.

    From where would the Admin page pull this errant sub-directory specification?

    Someone please help! (Maybe it's not an issue, but it's really annoying, and I have this sneaking suspicion that whatever causes the Admin page to display the '/blog' sub-directory will come and bite me some time in the future.

    (I am currently using an "Under Construction" plugin to prevent surfers from seeing the construction process. It works as intended, except that the front page does not show up when logged in, as it is supposed to, and as it does on the test site. That may be another effect of the errant "/blog" supposed subdirectory.)

    There is no /blog sub-directory on the site (although there was on the original test site). I just checked the test blog: http://thewellness.net, and it seems that the error was transferred from there. It's showing up the same way, even though the site works fine:

    Default	http://thewellness.net/?p=123
     Day and name	http://thewellness.net/blog/2011/06/02/sample-post/
     Month and name	http://thewellness.net/blog/2011/06/sample-post/
     Numeric	http://thewellness.net/blog/archives/123
     Custom Structure 	 /blog /%postname%/

    I'd really appreciate some help.

  2. You're not using MultiSite are you?

    Oh ... Hah. You are (I didn't notice where we are).

    The first blog on a MultiSite (when it's SubDirectories) always has /blog/ tossed in there. It's hardcoded.

  3. inge12
    Member
    Posted 2 years ago #

    Thanks, Ipstenu. I must have screwed up something in the database via manual editing, and the actual permalinks didn't use the /blog.

    That was fixed by changing permalink structure back and forth.

    Then, after some research, I discovered that just the post name would dramatically decrease performance when the site has more posts. So I changed to the /blog/year/month/postname structure.

    Thanks again!

    I think it's all working now!!

  4. I'm torn on that one myself :) I understand Otto's explanation as to why it's bad, but having read Yoast's about why it's not THAT bad I understand how to set up a server so I CAN do what I want. I don't generally advocate it unless you're someone who likes to play with your httpd.conf in VI ;)

    Still. With MultiSite, best to leave /blog/ in there for now for your main site. You CAN force it out, but should you ever re-save permalinks, it'll come back.

  5. inge12
    Member
    Posted 2 years ago #

    Hi Ipstenu,
    Yes, I read both Otto's and Yoast's explanation, and after reading Yoast's explanation, I figured that just the postname should be fine. But then I noticed the WordPress warning and I read someone's experience of noticeably slow response time after the database got bigger, causing that person to change the links to a numerically-based structure. So I changed back to year/month/postname -- before the blog went live. Some of the posts will be date-sensitive anyway, so that's fine.

    On another multi-site installation I'm planning (hope I won't need help on that one!), I will change the structure to /postID/postname because the material is not date-sensitive, and I don't want older posts to look "old" right in the address bar. ;)

    When I get there, I may need some help on what to do to ensure that old in-links will still work. Or I'll have to design a very helpful and appealing 404 error page. ;)

    As for the "/blog/" -- I did force it out -- through editing the database, thinking it was just a holdover from the blog sub-directory install. And, as you said, by switching permalink structure back and forth, the "/blog/" came back.

    I'm tech-ignorant enough that I'd best stay with the best-supported methods anyway. ;) That said, I did learn a lot through days of frustration in poring through the database -- both in text format and through MyPHP. Trouble is that I'm likely to forget it soon, concentrating on blog content, rather than technicalities. ;)

    Oh, well, when I forget, I'll just come back here, because you remember, seeing you deal with this stuff all the time. ;)

    Sure am glad you're patrolling these forums. :) Thanks again. :)

  6. As for the "/blog/" -- I did force it out -- through editing the database, thinking it was just a holdover from the blog sub-directory install. And, as you said, by switching permalink structure back and forth, the "/blog/" came back.

    FWIW, that's actually the second best way to remove it, if you're going to. (You can also do it on the network admin -> edit -> edit site -> Options screen, but you will always have to re-apply it when you save permalinks...)

  7. Oh, well, when I forget, I'll just come back here, because you remember, seeing you deal with this stuff all the time. ;)

    We take notes. ;)

  8. inge12
    Member
    Posted 2 years ago #

    Thanks to both of you. :)

Topic Closed

This topic has been closed to new replies.

About this Topic