WordPress.org

Ready to get started?Download WordPress

Forums

admin panel not opening (5 posts)

  1. aquilawebs
    Member
    Posted 3 years ago #

    I am getting a error message from few days on my WP , when ever i try to post a new page or even new post. As soon as i click publish the error comes up,

    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\test7\wp-content\themes\Minimal\functions.php:38) in C:\xampp\htdocs\test7\wp-includes\classes.php on line 1601

    this error also shows up in orange text at the bottom of my editor in WP_ADMIN , where we see "Last edited on January 23, 2011 at 4:43 am" things like this.

    Now i cannot open my WP-ADMIN this error comes up and not letting me log in.

  2. JarretC
    Member
    Posted 3 years ago #

    Did this error start when you first started using the Minimal theme? From what you posted it looks like there is a funcion that the theme itself is using that may be causing the issue.

    Where did you download the theme from?

  3. aquilawebs
    Member
    Posted 3 years ago #

    I got the theme from my client but i never touched functions.php

    here is the default code for function.php

    <?php

    require_once(TEMPLATEPATH . '/epanel/custom_functions.php');

    require_once(TEMPLATEPATH . '/includes/functions/comments.php');

    require_once(TEMPLATEPATH . '/includes/functions/sidebars.php');

    load_theme_textdomain('Minimal',get_template_directory().'/lang');

    require_once(TEMPLATEPATH . '/epanel/options_minimal.php');

    require_once(TEMPLATEPATH . '/epanel/core_functions.php');

    require_once(TEMPLATEPATH . '/epanel/post_thumbnails_minimal.php');

    function register_main_menus() {
    register_nav_menus(
    array(
    'primary-menu' => __( 'Primary Menu' ),
    'footer-menu' => __( 'Footer Menu' )
    )
    );
    };
    if (function_exists('register_nav_menus')) add_action( 'init', 'register_main_menus' );

    $wp_ver = substr($GLOBALS['wp_version'],0,3);
    if ($wp_ver >= 2.8) include(TEMPLATEPATH . '/includes/widgets.php');

    if (function_exists('add_theme_support')) {
    add_theme_support('post-thumbnails');
    set_post_thumbnail_size(164, 164, true);
    }

    ?>

  4. JarretC
    Member
    Posted 3 years ago #

    Seeing as how the theme loads 6 different files I'm guessing that the error is in one of those files. The code inside of functions.php that you posted shouldn't be causing any issues.

    Is there anyway to download the theme you are using from your client so I can take a further look?

  5. aquilawebs
    Member
    Posted 3 years ago #

    I got the same error again with the default theme of Wordress

    it says :

    Warning: Cannot modify header information - headers already sent by (output started at /home/aquilain/public_html/projects/creatovia/wp-admin/index.php:1) in /home/aquilain/public_html/projects/creatovia/wp-includes/pluggable.php on line 897

Topic Closed

This topic has been closed to new replies.

About this Topic