WordPress.org

Ready to get started?Download WordPress

Forums

Admin Pages Section HTTP Error 500 (13 posts)

  1. black_mezziah
    Member
    Posted 2 years ago #

    Hello,

    I may be needing help, I have this problem for a while now. I am encountering "HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request." when I open up my admin pages section "http://subdomain.domain-name.com/wp-admin/edit.php?post_type=page". This issue is only on that section other sections like "POST","SETTINGS" & etc. is all good.

    I have tried to resolve issue using "deactivation of some plugins" and changing settings on "config.php" and other files.

    Hope someone could enlighten me why I am encountering this and can give a little piece of solutions.

    P.S The site that I have been working on is adding multiple pages so far there are 4,724 pages and still adding. Also I am working on a sub-domain.

    Thanks,

  2. s_ha_dum
    Member
    Posted 2 years ago #

    Try to explain when this started and what settings you have changed.

  3. black_mezziah
    Member
    Posted 2 years ago #

    Hi thanks for your reply, actually this happens when I am adding pages, and before that I have created a plugin and installed it, then the pages section still working after awhile adding more pages, it collapse and I can't access it anymore it gives me that "HTTP Error 500 (Internal Server Error):...." error.

    I already remove the plugins that I have installed and still I am getting this error.

    What do you think cause this problem?

  4. Johnb81
    Member
    Posted 2 years ago #

    Did you try to upload a fresh install of WordPress? Backup your website first to be on the safe side.

  5. s_ha_dum
    Member
    Posted 2 years ago #

    I would start with Johnb81's suggestion. It does sound like you have a broken installation. Just treat it like a manual update.

  6. black_mezziah
    Member
    Posted 2 years ago #

    Already tried re-installing manually following steps on this link http://codex.wordpress.org/Updating_WordPress#Manual_Update, but still I am having the same error.

    Do you think this is because of too many pages? for now I do have added 4,903 pages.

  7. s_ha_dum
    Member
    Posted 2 years ago #

    Do you think this is because of too many pages? for now I do have added 4,903 pages.

    Doubtful. We've got over 10,000 posts, pages, and custom post type entries ( functionally they are all pretty much the same ), and I have heard of much larger sites. Something else is going on.

    What is your URL?

  8. black_mezziah
    Member
    Posted 2 years ago #

    I think so, because I do also read some of the post that wordpress could manage more than 10,000 posts, pages and custom types.

    I did try these codes:

    set "define('WP_DEBUG', true);" to true
    and add these lines,
    "error_reporting( E_ALL | E_STRICT );
    ini_set('display_errors', 1);"
    on the wp-config.php file and I ended up to these errors,

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: Undefined variable: post in /home5/affordm2/public_html/ncf/wp-content/themes/lawfirm/functions.php on line 701

    Notice: Trying to get property of non-object in /home5/affordm2/public_html/ncf/wp-content/themes/lawfirm/functions.php on line 701

    Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    Notice: add_custom_image_header is deprecated since version 3.4! Use add_theme_support( 'custom-header', $args ) instead. in /home5/affordm2/public_html/ncf/wp-includes/functions.php on line 2628

    I also use the default theme TwentyEleven but still I can't Access the Admin Pages Section.

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    What is your URL?

    If you can provide a URL it will be easier for us to locate the cause of the problem. If you do not want to post your URL, at best we can make guesses that may not be correct.

  10. s_ha_dum
    Member
    Posted 2 years ago #

    Are you sure that you are using an up-to-date Twenty-Eleven?

    Those notices really shouldn't break the site. They are all non-fatal.

    At this point, a lot of things are still possible, but I have seen this kind of thing with badly written .htaccess rules. What do you have in your .htaccess file?

    Another thing that is drifting to the top of my mind is that you are having actual server problems.

  11. black_mezziah
    Member
    Posted 2 years ago #

    Sorry I forgot to place my URL: http://ncf.olympiaroofing-company.com/

    Also on my .htaccess file I do have this line of codes:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  12. s_ha_dum
    Member
    Posted 2 years ago #

    That looks like a normal .htaccess file.

    I don't see any server errors now. You must have been doing some work. I do see some 404 errors on some of your resources. Like these:

    http://ncf.olympiaroofing-company.com/includes/PublishHead.js
    http://ncf.olympiaroofing-company.com/includes/video/html5/js/findlaw-players.js
    http://ncf.olympiaroofing-company.com/includes/PublishHead.js

    I expect that that is probably due to the use of relative URLs in some of the markup. Relative URLs are tricky inside WordPress because of the way that it and Apache conspire to lie about the site's directory structure.

    Just curious.... why does an "olympia roofing company" URL lead to a law firm's website?

  13. TIEPIEZ
    Member
    Posted 1 year ago #

    Hi all, I had something similar but figured it out with the help of my hosting provider.

    In my case I got the http 500 error when clicking on http://www.example.com/wp-admin/edit.php which should display the list of blogposts. This occurred more or less overnight and I hadn't made any changes before. And it's not that I have that many posts (45).

    Looking online, most resources pointed to apache resource settings so I contacted my server admin and they took a look. Turns out the memory_limit was set to 64Mb and the site required a bit more. This is usually enough for sites, so probably my site required more due to bad programming I did, but anyway, after setting memory_limit to 256Mb, everything worked fine again.

    This is probably not a "one fix fits all" but might help some of you.

Topic Closed

This topic has been closed to new replies.

About this Topic