WordPress.org

Ready to get started?Download WordPress

Forums

admin openid login option disappears with openid 3.0 (5 posts)

  1. zaneselvans
    Member
    Posted 5 years ago #

    After installing the openid 3.0 plugin (upgrading from wp-openid 2.1.2) the option to login to the admin interface using my openid URL is no longer available (though commenting using openid appears to work). Was this supposed to disappear?

  2. pdelisle
    Member
    Posted 5 years ago #

    I have the same issue!

  3. Will Norris
    Member
    Posted 5 years ago #

    a number of people have reported this issue, though I'm unable to reproduce it or determine what the cause is. Could you try temporarily deactivating all of your other plugins, just to see if it is a plugin conflict?

  4. jpick
    Member
    Posted 5 years ago #

    I just sent this to Will vie email:

    Okay, I figured out how to make it work:

    In wp-content/plugins/openid, rename wp-login.php to wp-login2.php

    Then modify openid.php:

    require_once 'wp-login2.php';

    I think the wp-login.php in the top level was getting included instead of the one in the plugin directory. Of course, I don't really know what was intended, so I might have messed things up. But at least now I see the OpenID login option on the login page.

  5. Will Norris
    Member
    Posted 5 years ago #

    Thanks Jim, I've fixed this in trunk and it will be in the next release.

Topic Closed

This topic has been closed to new replies.

About this Topic