WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
[resolved] Admin not redirecting to original domain (7 posts)

  1. alexdelgado
    Member
    Posted 1 year ago #

    I would like to have a mapped domain to redirect to my primary domain when a user attempts to login.

    example:
    mapped-domain.com/wp-admin => primary-domain.com/mapped-domain/wp-admin

    Right now what happens is that mapped-domain.com/wp-admin displays the login screen, but if you enter your credentials, it redirects you to the primary domain's login screen. I would like to avoid having to enter credentials twice.

    I have tried toggling the "Redirect administration pages to site's original domain" option, but it doesn't seem to be working the way I expect it to.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Can you post what you have for the settings in the domain mapping settings scren?

  3. alexdelgado
    Member
    Posted 1 year ago #

    Server CNAME domain: slnetwork.rutgers.edu

    [ ] Remote Login
    [x] Permanent redirect (better for your blogger's pagerank)
    [ ] User domain mapping page
    [x] Redirect administration pages to site's original domain (remote login disabled if this redirect is disabled)
    [ ] Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Do you have COOKIE_DOMAIN defined in your wp-config?

  5. alexdelgado
    Member
    Posted 1 year ago #

    I do not.

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Have you tried disabling all your other plugins and switching to the default theme?

    Also, if you want the login on the mapped domain to log you into the unmapped admin you need to have the remote login checked?

  7. alexdelgado
    Member
    Posted 1 year ago #

    Checking remote login did the trick. I misunderstood what that does.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.