WordPress.org

Ready to get started?Download WordPress

Forums

admin no permission to add categories (15 posts)

  1. computerwolf
    Member
    Posted 7 years ago #

    Ever since upgrading from 2.0.4 to 2.0.5, whenever I attempt to add a category, I get the message, "You don't have permission to do that." when on the page to add a new post. I am the administrator and can add categories fine from the category area in the admin. I have already attempted a fresh install of 2.0.5, and still receive the error.

  2. computerwolf
    Member
    Posted 7 years ago #

    If it helps any, I haven't noticed any other problems, but also haven't tried deleting posts or categories which were also affected on other versions that had this problem.

    Any help would be nice!

  3. Ovidiu
    Member
    Posted 7 years ago #

    hello,

    after upgrading to 2.1 I get this: You don't have permission to do that. when trying to ad category from the manage category menue. when trying to post to a new category it does not create the category instead it posts to the default category.

    please help. I am the only user and even after downloading and installing and checking with the rolemanager I can only say, that indeed my admin role has "manage categories" allowed, so whats wrong?

  4. Ovidiu
    Member
    Posted 7 years ago #

    the problem still persists, any clues on what to do?

  5. Ovidiu
    Member
    Posted 7 years ago #

    please excuse me for bumping this but I cannot add any categories :-(

  6. a1l3n
    Member
    Posted 7 years ago #

    I am having the same problem. One work-around is to use Alex King's Category Overload plugin.

  7. a1l3n
    Member
    Posted 7 years ago #

    Updating to WP 2.1.1 didn't fix this problem.

  8. Thi3rry
    Member
    Posted 7 years ago #

    You're right : the issue with capabilities management is still not fixed in 2.1.1. It sounds strange to use a plugin for the solely purpose of working around an unsolved WordPress bug.

  9. snarkattack
    Member
    Posted 7 years ago #

    I seem to have permission to do it but when I go to add a category through the Categories sub-panel, it doesn't actually appear.

    I can add them using the sidebar in the 'Write Post' panel but if I want the category to have a parent, then I have to manually edit it which also seems to be okay.

    Anyone else having that problem? I'm running WP 2.1.1...

  10. ssouci
    Member
    Posted 7 years ago #

    I also *cannot add new categories* (from anywhere in admin panel)

    have tried everything, fresh complete uninstall & install of WP 2.1 using Fantastico (at Lunarpages hosting)

    no matter what I try, when I enter info for new category (name etc.), then press the submit button - NOTHING happens

    no new category, no error message, button just flickers a tiny bit

    using WinXP, MSIE6 or FireFox, logged in as Administrator

    HELP please!

    BTW, the old version WP 2.0 worked for me fine when I ran a trial (but I never had chance to use it much)

  11. ssouci
    Member
    Posted 7 years ago #

    BTW, just tried WP 2.11 version, did not fix situation

  12. lisadragon
    Member
    Posted 7 years ago #

    Same here. I've had this problem since WP 2.1 and I thought 2.1.1 would have solved this issue. I dont get it why we can't add categories and why it seems like just a small amount (or just a small amount who decides to talk) but I have installed/upgraded for 3-5 other users on my domains and they all have the same prob, which makes me think that every WP 2.1 is flawed aka no permission to add categories, how come not a lot of people are saying something? Its pretty annoying having to get that script for every new install. T__T

  13. megsmind
    Member
    Posted 7 years ago #

    Add me to the list, in the create post screen there isn't even an option to create category.

  14. Doodlebee
    Member
    Posted 7 years ago #

    Pulling up a search gave lots of ideas on how to fix this:

    1) Use another browser
    2) Disable javascript in your browser
    3) create an administrator account in your WordPress install, change the original admin account "User" instead of "administrator" privileges, log out and log in under the new account. Give your original admin account back the admin privileges. Log out and back in as admin.
    4) Go to your Users area, change your account settings from "administrator" to "User" - then change it back without logging out.
    5) Disable your plugins. If you can add a category, activate them one-by-one to see which one is the culprit.
    6) Clear your browser's cache and cookies, restart said browser.
    7) A really REALLY tricky solution - it seems to work initially, but no promises - wp-includes/pluggable.php, lines 244 through 251, replace

    $cookie = explode('; ', urldecode(empty($_POST['cookie']) ? $_GET['cookie'] : $_POST['cookie'])); // AJAX scripts must pass cookie=document.cookie
      foreach ( $cookie as $tasty ) {
    	  if ( false !== strpos($tasty, USER_COOKIE) )
    			$user = substr(strstr($tasty, '='), 1);
    		if ( false !== strpos($tasty, PASS_COOKIE) )
    			$pass = substr(strstr($tasty, '='), 1);
    	}

    with

    `$user = $_COOKIE[USER_COOKIE];
    $pass = $_COOKIE[PASS_COOKIE];`

    (probably be an *excellent* idea to comment out the lines and add the new ones in, rather than delete and replace - in case this solution messes up anything majorly, you can always switch it back.)

    Anyway, these are only a *few* solutions I found when searching the forums for this issue. There were tons more.

  15. blkhearts
    Member
    Posted 6 years ago #

    Does anyone know if WP is working on a more straight forward fix? I have tried the above with swapping the lines in the pluggable.php file with no success. Upgrading to 2.1.3 has been annoying!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags