WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Link Problem (21 posts)

  1. wolfsbane
    Member
    Posted 6 years ago #

    Hi,

    In my Admin page, the link on the Tab "Dashboard" is pointing to http://www.mysite.com/wp-admin/admin.php?page=index.php
    instead of wp-admin/index.php.

    This is redirecting to the blank file index.php in the wp-content/plugins folder that I had placed to prevent listing the content of the plugins directory.

    What do i do to rectify this? I am on FF 2 and Win Xp if that helps.

    thanks,
    Vijay

  2. wolfsbane
    Member
    Posted 6 years ago #

    Any suggestions pls?

  3. wolfsbane
    Member
    Posted 6 years ago #

    This problem still remains unsolved.. Do ask if you need any other details

  4. wolfsbane
    Member
    Posted 6 years ago #

    Could somebody atleast direct me to a place where I can get a solution? Thanks~!

  5. infmom
    Member
    Posted 6 years ago #

    Good luck... I'm having the same problem and nobody's come up with an answer for me either. Sigh.

  6. whooami
    Member
    Posted 6 years ago #

    this is a searchable issue.

    as for the answer, rename the index.php that is currently inside your wp-content/plugins directory to index.html.

  7. nicholutso
    Member
    Posted 6 years ago #

    I don't know if this is the appropriate thread, but its the most active. I have some custom code that lives outside the wp-admin folder, and its linked to correctly in menu.php it spits out a page with a form on it. At the top of the page I use:
    <?php
    require_once( $_SERVER['DOCUMENT_ROOT'] . '/wp-admin/admin.php');
    $title = __('Edit Inns');
    $this_file = 'inn.php';
    $parent_file = 'inn.php';
    require_once( $_SERVER['DOCUMENT_ROOT'] . '/wp-admin/admin-header.php');
    ?>
    to pull in the wordpress admin menu, but its not pulling in my plugin menu items (specifically cforms II) any suggestions?

  8. searchen
    Member
    Posted 6 years ago #

    whooami:
    you refer to an index file in the plugins directory... I don't have such a file. Neitehr index.html or index.php

    What is this?

    Peter

  9. maxguncel
    Member
    Posted 5 years ago #

    I had the same problem.

    There was an empty index.php file in my /wp-content/plugins/ directory and i replaced it with an empty index.html file and it's OK now.

  10. ederic
    Member
    Posted 5 years ago #

    I was also able to fix the problem with whooami's solution.

    thanks, whooami. :)

  11. whooami
    Member
    Posted 5 years ago #

    youre welcome, ederic :)

  12. tigrlily
    Member
    Posted 5 years ago #

    I also lack any index plugin. I have been unable to post anything for a couple of weeks to my organization's site. Please help!

    Every time I try to save or publish I get a blank page http://www.sitename.com/wp-admin/post.php.

    The plugins I have are below. They are all deactivated. I had not changed or updated anything when I started having issues.
    Akismet 2.0
    Hello Dolly 1.5
    wp-cache 2.0.19
    WP-FLV 0.2

  13. catsandbeer
    Member
    Posted 5 years ago #

    replacement of index.php in plugins folder with index.html (and deletion of index.php) worked for me as well

  14. Edde Beket
    Member
    Posted 5 years ago #

    @maxguncel: strange behaviour, but your tip did it! Thanks!

  15. Chetan Gole
    Member
    Posted 5 years ago #

    I was having same problem, that was really strange, but now it worked due to trick given by whooami !!

  16. engineerofsuccess
    Member
    Posted 5 years ago #

    Is anyone having Wp-admin login problems? My login page is blank after upgrading to the newest install

    http://www.ShawnDrewry.com

  17. blogsdna
    Member
    Posted 5 years ago #

    @engineerofsuccess please read the reply of other users (renaming index.php to index.html) this might solve your problem.

  18. Suburbanmom
    Member
    Posted 5 years ago #

    Is anyone having trouble logging on to their admin page today 1/1/09? I was on this morning until early afternoon, then nothing...

  19. miguelnetto
    Member
    Posted 5 years ago #

    I have the same problem at the dashboard link http://fotodigitalbrasil.com/wp-admin/admin.php?page=index.php (WP 2.7). When I click in Panel link he show me only the left columm and the central content is blank in dashboard. Only work if I delete in the URL http://fotodigitalbrasil.com/wp-admin/admin.php?page=index.php this one admin.php?page=index.php and use only http://mywebsite.com/wp-admin/.

  20. utele
    Member
    Posted 5 years ago #

    I had the problem with the link after upgrading to 2.6x
    http://www.mysite.com/wp-admin/admin.php?page=index.php
    instead of wp-admin/index.php.

    It wasn't great, but the workaround to use the address line and enter .../wp-admin/ worked.

    Now after upgrading to 2.7 the workaround didn't help. Therefore, I tried the solution with the index.php in all directories, where only a index.php for safety reasons exist I changed the index.php to an index.html.

    Unfortunately, it did not help. I've still no content in the dashboard except the menu...

  21. utele
    Member
    Posted 5 years ago #

    ...I already stated the problem here:
    http://trac.wordpress.org/ticket/8260

Topic Closed

This topic has been closed to new replies.

About this Topic