WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Admin Login stuck in a loop? (21 posts)

  1. schillerbrand
    Member
    Posted 11 months ago #

    Funniest thing... I have WP 3.5.1 up and running and it works great. I am able to log on to my dashboard through the Admin login page. However, I just found out that if I click on any Theme's Customize link or Live Preview link it takes me to the page where you see the themes attributes in the left-hand column and WP asks you to log in again as the Admin.

    Here's the strange thing, I typed in my password, for brief second I see that it says I have successfully logged in and then the page seems to reboot itself and go back to the Admin login page and displays an error that I have not successfully logged in.

    Everything else seems to work fine, I just can't customize any theme or even live preview it because of this login loop. Any suggestions?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    Can you replicate the problem using the default 2012 theme with all plugins deactivated?

  3. schillerbrand
    Member
    Posted 11 months ago #

    I deactivated all the plug-ins, deactivated my current theme and made the default 2012 theme the current one. The problem still exists.

    When I click on either Live Preview or Customize WP takes me to the new page where I see the themes information in the left-hand column and the login box in the center of the screen. I enter my login information that I'm using to log into my site and the loop begins.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    Site url?

  5. schillerbrand
    Member
    Posted 11 months ago #

    the URL is http://maryandstephan.com

    I just turned on the old theme I was using since it didn't seem to make much of a difference.

  6. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    We need to see the site using the default 2012 theme with all plugins deactivated.

  7. schillerbrand
    Member
    Posted 11 months ago #

    sorry about that. I have put the website to the default 2012 and all plugins are deactivated. still have the looping problem.

    http://maryandstephan.com/wp-admin/customize.php

  8. schillerbrand
    Member
    Posted 11 months ago #

    Hi esmi, Did you have a chance to look at the website? The problem has not gone away and I have to turn back my theme because people are visiting the site.

  9. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    We still need to see the site using the default 2012 theme with all plugins deactivated.

  10. schillerbrand
    Member
    Posted 11 months ago #

    Okay, all done! all plugins off and back to 2012 theme.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    Now can you access the Customizer effectively and preview view (say) the Twenty Eleven theme?

  12. schillerbrand
    Member
    Posted 11 months ago #

    Nope. it still does the same thing. I try to logon through the admin panel it flashes for a second that I have successfully logged on, and then it goes back to a screen that says "Your session has expired. Please log-in again."

    take a look http://maryandstephan.com/screenshot.png

    [This is a forum - not online chat. No bumping. If it's that urgent, consider hiring someone.]

  13. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  14. schillerbrand
    Member
    Posted 11 months ago #

    Would I still be able to keep all of the work that I did in another theme by following these directions?

  15. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    Yes. Your site's content is stored in your database with the exception of uploaded media files stored in the wp-content folder. So as long as you avoid that folder, you will be fine. All you are doing is uploading a fresh set of WordPress core files.

  16. schillerbrand
    Member
    Posted 11 months ago #

    Ugh! I did exactly what you told me to do.

    I threw away all of my WordPress files except the content folder. I uploaded a new version of WordPress 3.5.1 and went through the configuration process in my browser. I then logged on and went straight for the appearance section. I clicked on Manage Themes>Twenty Twelve> Customize and the same thing happens. The admin portal comes up and says my session has expired.

    Is this a problem with the database? Should I create a new one?

  17. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    No - I think it's a problem with cookies. What happens if you use another browser? Or another computer?

  18. schillerbrand
    Member
    Posted 11 months ago #

    This gets crazier all the time. I am a Mac user and was working on Firefox onto. I tried logging on with Safri and got this browesr error code

    http://maryandstephan.com/wp-login.php?redirect_to=http%3A%2F%2Fhillerbrandmagsamen.com%2Fwp-admin%2F&reauth=1
    and it reloaded the page with the Username as lowercase "admin" not the default uppercase "Admin" which I use.

    Chrome does the same thing???

    SO I rest my password through Chrome and still have the same problem.

    How can I use WP if I cant customize it. What could be wrong on my end?

  19. planethax
    Member
    Posted 11 months ago #

    I had something similar yesterday and it was an active plugin.
    I had to go to database and remove it as I could not access site at all.

    what do you have that is trying to redirect to hillerbrandmagsamen dot com?

  20. schillerbrand
    Member
    Posted 11 months ago #

    oh my goodness! You solved it!!
    I have 2 domain names that take you to my ISP. In WordPress, I had configured it as such:

    WordPress Address (URL) http://maryandstephan.com
    Site Address (URL) http://hillerbrandmagsamen.com

    Once I changed the Site Address (URL) to the maryandstephan.com everything works perfectly now! That is so strange?

    I would have like to create the who WP site configured to have both the WordPress Address + Site Address as hillerbrandmagsamen.com.

    Is there a way to do that by reinstalling something?

  21. schillerbrand
    Member
    Posted 11 months ago #

    thank you everyone for being so patient! I figured out my last question.

    Something interesting to note as we close this discussion, I have been noticing for a long time how slow the site was running and couldn't figure out why. Once I made both the WordPress URL and site address URL the same, the whole thing just is superfast.

    Thanks again!

Reply

You must log in to post.

About this Topic

Tags