WordPress.org

Ready to get started?Download WordPress

Forums

admin login problem when update to 2.6.2 (13 posts)

  1. phoria
    Member
    Posted 5 years ago #

    I tried to upgrade my wordpress from 2.5 to 2.6.2, I followed every steps. But the problem is I can't login. I read on many posts before, that suggest delete my .htaccess files, but still didn't solve the problem. I even try to re-install my wordpress, and re-import my sql database, and it didn't work too.

    my blog is http://raccoonnest.com/

    does anybody know how to solve it ?
    thanks.

  2. hanni
    Volunteer Moderator
    Posted 5 years ago #

    What happens when you try to log-in?

  3. phoria
    Member
    Posted 5 years ago #

    it said Internal Server Error.
    try this address http://raccoonnest.com/istiyanto/wp-login.php

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@raccoonnest.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.9 (Unix) mod_ssl/2.2.9 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at raccoonnest.com Port 80

  4. moshu
    Member
    Posted 5 years ago #

    Reinstalling never solves anything. That's an urban myth...

    Now, you used to have the setup described here:
    Giving_WordPress_Its_Own_Directory
    but at this moment you do NOT have index and htaccess in the subfolder
    http://raccoonnest.com/istiyanto/

    Read the tutorial again, put back the missing files and let see from there. Note: you do need the WP short index.php (and htaccess if in use) in BOTH the root and the install folder; the one in the root has to be modified according to the tutorial!

  5. phoria
    Member
    Posted 5 years ago #

    I already follow the instruction as you said before. I put the missing files (index.php and .htaccess) in http://raccoonnest.com/istiyanto/
    but it still doesn't work.
    could it be my database problem ?

  6. moshu
    Member
    Posted 5 years ago #

    No, files related error messages are never database related.
    Are you sure you have the right index and htaccess in the install (istiyanto) directory?
    Don't just copy over from the root - they must be edited.

  7. phoria
    Member
    Posted 5 years ago #

    I edited index.php as in the tutorial. but the .htaccess files inside /istiyanto directory is empty.
    Should I put the code in the .htaccess files both root and (istiyanto)directory ?

  8. moshu
    Member
    Posted 5 years ago #

    Yes, but that also should be edited.

  9. phoria
    Member
    Posted 5 years ago #

    can you give me some tips or links on how to edit my .htaccess files ?

  10. moshu
    Member
    Posted 5 years ago #

    Well, I assume the one in the root looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    So, the other one, in the istiyanto directory, where the WP install is, should be like

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /istiyanto/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /istiyanto/index.php [L]
    </IfModule>
    # END WordPress

    At least, this is how it is on a similar setup of mine.

  11. phoria
    Member
    Posted 5 years ago #

    thank you. but it doesn't work too. after i tried to get into login page, it came back to the main page again.

  12. moshu
    Member
    Posted 5 years ago #

    I am running out of ideas...
    Unless there is something very unusual in your whole setup - that should work.

    I am afraid I can't help further without taking a closer look at it.

  13. katpatuka
    Member
    Posted 5 years ago #

    I had a similar problem with the blog - being in a subfolder of root - working fine but I could not login with the wp-admin and instead getting the ominous Internal Server Error message. After studying the errorlog of my site's admin interface (example: Fri Nov 28 12:12:43 2008] [error] [client 12.34.56.78] SoftException in Application.cpp:252: File "/home/abcdefg/public_html/pension/wp-login.php" is writeable by group) I saw that some files in the WP folder had chmod 666 set

    After chmod those files to 644 with the ftp client the problem vanished.

Topic Closed

This topic has been closed to new replies.

About this Topic