WordPress.org

Ready to get started?Download WordPress

Forums

Admin comments are being marked as spam (10 posts)

  1. ArtWave
    Member
    Posted 1 year ago #

    Greetings,
    In the last few months I've been running into a very odd and confusing issue, where every time I reply to a comment on my blog it keeps going to spam...I'm the Admin of the site and replying as the Admin. Obviously this is very strange !!
    This wasn't happening from the beginning of the site installation, or for 3-4 years since the site has been live & functioning. I noticed it about a year ago and it keeps persisting, even after I go to the spam and mark them 'not spam'.

    The only spam kind of plugin I have installed is "WP-SpamFree" plugin....but this plugin has been installed for a few years now, even when this wasn't happening.

    Obviously I'm not sure if it's a plugin that is causing it....or some weird glitch.
    My sites url is: http://www.fulfilleddestiny-s3.com/blog

    I would greatly appreciate anyone who can assist in fixing this odd bug!!
    Please help and thank you :)
    Aline

  2. CedarPointConcepts
    Member
    Posted 1 year ago #

    I would check your spam plugin and see if there is some sort of block list. I didn't see a plugin by that name so I'm not sure which one you are using. Otherwise I would disable the plugin and see if the problem goes away.

  3. ArtWave
    Member
    Posted 1 year ago #

    Thank you for your response :)
    Here's a link to the actual plugin that I'm using, not sure if it helps...
    http://www.polepositionmarketing.com/library/wordpress-plugins/wpspam-free/
    Although I did notice that their latest version was done 2010...so it might be a possibility that it's clashing with the more recent versions of WordPress.

    However, I will try your suggestion...see what happens :)
    and of course get back...

    Again very much appreciate your assistance !!!!

  4. ArtWave
    Member
    Posted 1 year ago #

    hmmm....so I deactivated and deleted the plugin...then I went to reply to a comment and it still went to spam :(

    Any other suggestions...thoughts?

  5. CedarPointConcepts
    Member
    Posted 1 year ago #

    Check your comment blacklist in Settings>Discussion. If anything is there make certain that nothing pertains to you (IP, username, common words used in replies, etc). Also make sure that anything in there is on its own line with no empty lines.

  6. ArtWave
    Member
    Posted 1 year ago #

    I checked my settings in discussion....and there were a few ip address listed in the blacklist...however not mine :)
    In either case I deleted them anyway, saved and went to reply to a comment again... unfortunately it still went to spam :(

    Very weird and a tad bit frustrating....

    Maybe this experience I had about a year ago may assist:
    I had 2 admins in my users once, and there is only 1...so after much research and assistance from wp folk, I was able to get rid of the 2nd (hidden) admin that was showing....it had turned out that perhaps it was some hacker that had created it....long story short....I took care of it and never happened again.

    Do you think this may be somehow connected?
    I would doubt it, considering that it's my ip/admin that's going to spam...

    Have you ever heard or read of this same situation happen before?

    I am determined to get to the bottom of this issue and resolve it....and of course your assistance is greatly appreciated !!

    I am open to any and all suggestions :)

  7. CedarPointConcepts
    Member
    Posted 1 year ago #

    Certainly strange behavior. Make certain that you do not have any other plugins that would be causing this (eg. Akismet). The only posts where I have read of this happening are plugin related.

  8. ArtWave
    Member
    Posted 1 year ago #

    It is definitely strange behavior :(
    The funny thing is that I don't have Akismet plugin installed on our site.
    And from doing a bit of research it seems that Akismet would be the only other possible plugin that might cause that.
    I don't have any other 'spam' related plugins installed...I even uninstalled and deleted the WP-SpamFree plugin which didn't really fix the issue.
    hmmmm...mind boggling eh...

    The other option I have is to upgrade our wordpress version to the latest (am running 3.3.1 right now) and see what happens.

    Again, I so so so appreciate your assistance!!!!!
    And still open to any other suggestions....am hopeful that we'll get to the bottom of it and find a solution.

    Looking forward and openly receiving any and all suggestions :)

  9. CedarPointConcepts
    Member
    Posted 1 year ago #

    Certainly strange. I should have noticed you were using an older version of WP. I definitely recommend upgrading to 3.4.2.

  10. ArtWave
    Member
    Posted 1 year ago #

    So it seems after updating WordPress to the latest version 3.5.1 didn't fix the issue :(
    However, I also installed Akismet plugin, (which I did not have installed before) and it's showing me that Akismet has marked it spam.
    The strange thing is that whether I have Akismet installed or not, my admin comment is still being marked as spam. Although after I un-spamed it, Akismet marked it as 'false positive'.

    I did find this article regarding the 'false positive' http://akismet.com/support/#ht9 which I'm a little unsure of how to best take the steps to ensure my admin comments don't get marked as spam again.

    In the article from the link above, it mentions that CAPTCHA plugins may also cause this to happen.
    There are 3 plugins that are Captcha related that I do have installed, they are:
    1. Really simple Captcha (this to go with Contact Form 7 plugin)
    2. WP-reCAPTHCA
    3. Register Plus

    These 3 plugins I have had them installed for a few years now, so it's definitely not Akismet, as I only installed it now for the first time.

    Anywho, I really hope someone is able to assist me on fixing this issue.
    Looking forward :)

Topic Closed

This topic has been closed to new replies.

About this Topic