WordPress.org

Ready to get started?Download WordPress

Forums

Admin charset problem/pagelayout after upgrade 2.2 (19 posts)

  1. Jack
    Member
    Posted 7 years ago #

    After a testupgrade I just upgraded my official weblog. This went much better than the test (???), but with these few notes:

    1. The charset of my admin is not right. My blog is still latin1. My blog looks ok, but the characters in the admin look like this: Pagina’s. I can fix this by changing the charset under 'options > reading', but then my blog would display questionmarks all around.
    How can I fix this?

    2. In my testsite I seemed to have a different layout of several admin pages, ie the categorylist etc. But now with the real upgrade everything still looks the old way. How come?

  2. moshu
    Member
    Posted 7 years ago #

    Did you mess with the charset and collation during the upgrade?
    There is a guide in the codex:
    http://codex.wordpress.org/Converting_Database_Character_Sets
    (not complete yet!)

  3. Jack
    Member
    Posted 7 years ago #

    No I did not. This problem with the strange characters in the admin menu actually was already present after my upgrade to 2.1, and I thought 2.2 would fix the problem.
    In the meanwhile I didn't change anything in my database or otherwise.

    In short: Read options says: iso-8859-1 (from the beginning of my blog) and charset in the head.php of pages says latin 1. So does the header.php within de admin folder.
    Strangely enough the blog reads ok, but the admin not.

    Any ideas?

  4. moshu
    Member
    Posted 7 years ago #

    To be honest, I don't know what "head.php" is. Is this is your theme folder?

    And the encoding/charset should never be hard coded, in the themes' header file or in the admin-header; it is always called by template tags/functions, e.g.
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php echo get_option('blog_charset'); ?>" />
    (for admin)
    or

    <meta http-equiv="Content-Type" content="text/html; charset=<?php bloginfo('charset'); ?>" />
    (for themes)

  5. Jack
    Member
    Posted 7 years ago #

    I'm sorry, I meant 'header.php' in my themesfolder in which it says

    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

    so it's not hard coded, nowhere.

  6. Romik84
    Member
    Posted 7 years ago #

    and where is the Preview window??Huh?Wordpress lost much with this :(

  7. Jack
    Member
    Posted 7 years ago #

    Romik... what IS strange is that the preview window WAS present in a clean install with imported backup (including several other modifications), but NOT in the regular upgrade...
    Something did not go entirely well during upgrading I think. I guess we'll see version 2.2.1 soon ;)

  8. moshu
    Member
    Posted 7 years ago #

    Romik84, search and/or start your own topic - don't hijack.

    The preview is there - it only opens in a new window. The link to it should be on the top right of the writing area.

  9. Jack
    Member
    Posted 7 years ago #

    Hey Moshu, but that's what's happening (although this, as you pointed out had nothing to do with my question ;)): In my test installation I saw the button you mention and a lot more, but NOT in my 'real' upgrade. Though it clearly states version 2.2 at the bottom of the page...?

    In fact... it seems as if the whole admin wasn't upgraded.

  10. moshu
    Member
    Posted 7 years ago #

    Did you try to upload the admin folder again?

  11. Jack
    Member
    Posted 7 years ago #

    Yes, two times and also running upgrade.php again, but it says the database tables are already updated.

  12. moshu
    Member
    Posted 7 years ago #

    In that case, I am running out of ideas :(

    Although, the DB might be updated, however having uploaded corrupt files is still a possibility.
    When you say you uploaded the admin folder - do you mean new, fresh copy (aka new download, new unzip)?

  13. Romik84
    Member
    Posted 7 years ago #

    moshu,I know about that View URl. I hope the preview will be back soon. What about undo and redo keys :/? The same?

  14. moshu
    Member
    Posted 7 years ago #

    I still say: open your topic or, most importantly, search before posting...

    You can hope, but the preview has been eliminated by the main dev:
    http://trac.wordpress.org/changeset/5159

  15. Jack
    Member
    Posted 7 years ago #

    I just downloaded WP2.2 again etc., and now the preview button is back (I'm scratching my head now ...). Could there have been something wrong with the first download?
    Anyway, that's ok now :).

    Back to my original question I can add that in my testsite the character encoding is ok in the blog as well as in the admin. What I did was make a new database (standard set to utf8, both charset and collate), and imported a backup (latin1 for the wp-tables). Then changing the charset in the 'read options' from latin1 to utf8 and everything was ok.

    But I quess this is not a good way to go about this?

  16. moshu
    Member
    Posted 7 years ago #

    In my first post here I gave you a link regarding changing character sets...

  17. Jack
    Member
    Posted 7 years ago #

    Yes, I know the article and read it. Also that it is a draft and that the author is still working on it, so untill now I dare not to use that :).

  18. moshu
    Member
    Posted 7 years ago #

    I dare not to use that

    You just did, according to you:
    make a new database (standard set to utf8, both charset and collate), and imported a backup (latin1 for the wp-tables).

  19. Jack
    Member
    Posted 7 years ago #

    Well, I dare all kinds of things with a database just for testing purposes ;), but what is described in that article is not the same as what I did, or is it? In my case the backups from that installation still have the latin 1 encoding mentioned at the beginning of all tables but for the rest it's all utf8! And starting with new posts written in utf8 next to the old ones written in latin1 seems to be working. Or am I overlooking something?

Topic Closed

This topic has been closed to new replies.

About this Topic