WordPress.org

Ready to get started?Download WordPress

Forums

Admin bar disappears when I switch to www.SiteName.com (7 posts)

  1. justinta
    Member
    Posted 1 year ago #

    I have been developing my site in a sub-directory
    subdirectory.mydomain.com
    and everything is working fine - the Admin bar shows.

    I changed the Site Address to http://www.mySiteName.com
    in Setting>General
    and when I 'View Site' - No admin bar.

    Any ideas why my admin bar will not show when I point to http://www.mySiteName.com?

    It works for my other sites with the same theme

  2. nicknormal
    Member
    Posted 1 year ago #

    Users -> All users -> your profile, click 'Edit'
    Make sure 'Show Toolbar when viewing site' is ticked ON.

  3. inspired888
    Member
    Posted 1 year ago #

    I have the same issue. It's been commonly reported for a considerable period of time. So not new.
    I have not found a solution. At least not one that worked.
    It seems that when the site is installed in a subfolder and then the URI is set to the root (or simply a different "folder") two things break.
    1) The admin bar vanishes.
    2) The site does not "think" you are logged in, which means things like "edit post" links don't show up.

    My guess is that it's a cookies issue causing both problems. Which suggests to me it's a bug or feature deficiency in the way WP handles admin cookies.

    I'd love to find a working solution.

    One solution folk reported working was to add @define(‘ADMIN_COOKIE_PATH’, ‘/’); into the config.php file. However, on my site this made no difference.

    Let me know if it makes a difference for you.

  4. justinta
    Member
    Posted 1 year ago #

    Hi Nick & Inspired,
    Thank you for replying!
    I checked my user settings & the Show toolbar is checked.
    Adding the @define statement did not work either.

    Hopefully a solution will be found - a silly frustration.

  5. cynnie88
    Member
    Posted 1 year ago #

    You might have to run a search and replace on the database to update any old references to the url.

  6. inspired888
    Member
    Posted 1 year ago #

    @Cynnie

    You might have to run a search and replace on the database to update any old references to the url.

    Thanks for helping. Are you saying that there might be configuration settings in the database which are sticking with the old URL? I am aware that within posts (images, media, links, etc.) the old URL can stick around and needs to be updated manually or with a search/replace plugin, but I was not aware that configuration settings might keep the old URL, and surely only a system/core related setting would affect the admin authorization at the front-end. Right?

  7. ygirod
    Member
    Posted 1 year ago #

    I'm also looking for a solution.

Topic Closed

This topic has been closed to new replies.

About this Topic