WordPress.org

Ready to get started?Download WordPress

Forums

Admin Area - Number of Posts per Page (11 posts)

  1. oliviaheart
    Member
    Posted 5 years ago #

    How can I increase the number of posts per page in the ADMIN area?

    (I already know how to do this for the actual blog website.)

    I would also like to increase the number of comments per page in the ADMIN area?

    I need to be able to see more than 15 or 20 at a time.

  2. GrandSlambert
    Member
    Posted 5 years ago #

    It sounds like your question was answered in an older post here:

    http://wordpress.org/support/topic/145133?replies=11

    Look at the last post. However, I tried to do that with a blog I have and it doesn't seem to work for version 2.7.1.

  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Please check with this in wp-admin/edit-page.php :

    wp("post_type=page&orderby=menu_order&what_to_show=posts$post_status_q&posts_per_page=-1&posts_per_archive_page=-1&order=asc");

    Thanks,

    Shane G.

  4. GrandSlambert
    Member
    Posted 5 years ago #

    No, that is NOT it. That setting changes the number of posts on the site pages but NOT in the ADMIN, as stressed by the original poster - hence the all caps on the word ADMIN. Please read the original question carefully as the original poster knew how to do what you told them, but there is no simple setting to change how many are displayed on the admin side.

  5. anjaliom
    Member
    Posted 5 years ago #

    admin/edit-pages.php

    line 190
    $per_page is set to 20

    Change that and You're goog to go.

  6. Kevin Leary
    Member
    Posted 4 years ago #

    For me it was line 823 of wp-admin/includes/post.php, and for some reason it works when I change:

    $posts_per_page = 40;

    but if I try:

    $posts_per_page = 100;

    The page breaks. Any ideas why?

  7. HamidProg
    Member
    Posted 4 years ago #

    I edited wp-admin/includes/post.php

    I edited line 805@

    wp("post_type=post&what_to_show=posts$post_status_q&posts_per_page=15&order=$order&orderby=$orderby");

    and line 841@:

    $q['posts_per_page'] = 15;

    -----

    If you change both numbers to the number of posts you want to view, it should work. I've tested it live on a 2.7.1 WP blog with 100, then 150, then 250 posts per page. I tried to get 1500 posts per page but that crashed the admin. 999 posts per page works. Best to find the number that suits you, 1000 may not be the maximum.

    Hope that helps.

  8. Mark / t31os
    Moderator
    Posted 4 years ago #

    You can change this in 2.8 under screen options when viewing posts..

    So no changes to core files required for those of you using the latest version..

  9. transitionpete
    Member
    Posted 4 years ago #

    t31os_ said: You can change this in 2.8 under screen options when viewing posts. So no changes to core files required for those of you using the latest version.

    I'm using WP v2.8.6 and it seems to be broken... I had gone in to increase the number of posts in the POSTS > EDIT SCREEN OPTIONS subpanel and now I see NOTHING on the /WP-ADMIN/EDIT.PHP page!!!

    I had increased from the default 20 posts to 400 and the resulting refresh draws a blank page. Where and how can I fix this? What, if any, is the limit for the number of posts for this function?

  10. transitionpete
    Member
    Posted 4 years ago #

  11. pumpkinslayer
    Member
    Posted 4 years ago #

    Thanks @t31os_ there it is. Nice.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.