WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] admin-ajax.php issue (16 posts)

  1. Dugs
    Member
    Posted 5 months ago #

    Hi

    I am using wordpress 3.8.1 with woocommerce 2.1 and the latest Hueman theme. I have reviewed the page speed via http://tools.pingdom.com and noticed that there is excessive strain on the file wp-admin/admin-ajax.php - the actual page loads anywhere from between 635ms to 3secs but wp-admin/admin-ajax.php continues to respond between 5 to 20 secs after the page is loaded.

    I looked into this in more details and discovered that it is Woocommerce sending the requests. Even when I deactivated the plugin and keep it installed this still occurs. I have tested by removing all plugins and its definately woo commerce causing this issue and strain on the db.

    Can you confirm if there is a way to lessen the impact on this file or if this is just how this plugin works?

    Thanks

    https://wordpress.org/plugins/woocommerce/

  2. cjurczak
    Member
    Posted 5 months ago #

    I too am having trouble with the wp-admin/admin-ajax.php file causing lots of CPU/Memory usage. This is causing my host to trip my site offline for several minutes at a time. I am also running 3.8.1 and 2.1 like the op. My host reccomends I deactivate whatever is using this file, but Woocommerce is kind of essential to my website.

  3. Roy Ho
    Member
    Posted 5 months ago #

    Strange, I just tested couple of my sites on pingdom and ajax-admin.php came back with around 270ms...This is on the default shop page...

  4. cjurczak
    Member
    Posted 5 months ago #

    Pingdom is returning in the 960-980ms range for me

  5. cjurczak
    Member
    Posted 5 months ago #

    I have inserted some code into my functions.php in my theme directory that supposedly disabled the wordpress heartbeat, and disabled plugins one at a time and pingdom returned similiar wait times for admin-ajax.php each time...

  6. laurabfont
    Member
    Posted 4 months ago #

    I am having this same issue cjurczak and I followed the same steps as you. Were you able to resolve this? My site is so slow!

  7. cjurczak
    Member
    Posted 4 months ago #

    Disabling the heartbeat did help some, but admin-ajax.php is still a big part of my loading time. Worth doing though...It took my site from being unuseable to atleast useable.

  8. laurabfont
    Member
    Posted 4 months ago #

    thanks so much cjuczak. i disabled the heartbeat but didnt see much of a difference on my site. i also asked woothemes for some help on this. my checkout process is grueling.

  9. cjurczak
    Member
    Posted 4 months ago #

    Something else to try is log out of the admin console, and try your site. My site seems to crawl worse when I'm logged in. Not that this is "right" but might help in troubleshooting for those who know more about WordPress than we do...

  10. laurabfont
    Member
    Posted 4 months ago #

    yeah i tried logging out as well but nothing is helping. users are complaining about the site being broken because of how painfully slow the process is

  11. Dugs
    Member
    Posted 4 months ago #

    Hi there,

    I never actually found a fix for this or got a response from woocommerce. So still unsure why it has so much of a strain on this function. There was a recent woocommerce upgrade so not sure if that would have helped.

    I made the change to the heartbeat which slightly improved things for a while. I also signed up to Cloudflare CDN which helped but eventually with an increase in traffic it started to slow down again until I couldnt really do anything within the wordpress admin panel without smashing my monitor in frustration. So the only way I found to resolve was to upgrade hosting which I had been putting off for a while. I moved from my shared hosting to VPS and pages are loading fast and although I can still see the load times for admin-ajax.php slow in pingdom it doesnt affect the overall load time of the page as it seems to be counted as a background process. So with VPS and also cloudflare my site can handle it no probs even with a spike in traffic.

    WordPress in general seems to need a lot of power behind the scenes so if you add a lot of plugins and have a lot of posts + traffic then eventually you will outgrow shared hosting (unless you are having this issue with VPS).

    The only problem with that is to move to VPS with the hosting company I was with was really expensive as they were looking for $100 a month. They were actually helpful when I was on shared hosting trying to resolve this as they increased the CPU to around 60% when I should have only had 25% but I just couldnt justify paying their monthly fee for VPS. So I looked around at the hosts wordpress.org recommend and choose one of those. Costs about $15 for 1st month then moves to $25 a month for my VPS.

    On shared I was paying only $80 a year but it was worth the upgrade just so I can keep all the functionality on the site. I've also been able to add plugins back on that I had to remove to help speed up the site and it doesnt have any impact on speed.

    Would have preferred to find a solution that would work on my shared hosting set up but I just couldnt deal with the hassle anymore.

    Its not a fix but it just means that you can concentrate on the content on your site rather than worrying about if people are going to get frustrated by how slow your site is.

    cheers

  12. laurabfont
    Member
    Posted 4 months ago #

    Thank you worddug - this is helpful. I am using VPS (digitalocean) but still seeing this issue

    -using woocommerce with stripe and paypal (both equally slow ~90+ seconds after payment submitted)

    -Using https but issue persists with http and https

    -server: 2GB Ram 30GB SSD Disk

    -('WP_MEMORY_LIMIT', '96M'); php_value memory_limit 64M

  13. laurabfont
    Member
    Posted 4 months ago #

    i disabled the new order email notification and this SIGNIFICANTLY improved the load time. The load time is still not ideal but this is the only thing that has seemed to work. Please note, I did not disable customer email notifications, just the email that gets sent to me when a user submits an order. Easy fix and very helpful.

  14. cjurczak
    Member
    Posted 4 months ago #

    My shared host keeps kicking my site offline for exceeding my allocated CPU/RAM/Virtual Ram limits. My admin-ajax.php load times are still higher than expected, but is there a way to find out what is using all my resources, and causing me to get kicked offline. My site is only getting 50-100 visits per day, most of time resource usage is high when I'm making changes via the admin panel.

    Does anyone know why disabling the new order email notification would improve load time? It seems like and odd thing to help. My host is wanting me to wipe WP, and start from a new install, which I am NOT wanting to do.

  15. Dugs
    Member
    Posted 3 months ago #

    I decided to uninstall woo commerce as I wasnt happy with it after another couple of issues with customer orders. My overall page speed has improved by more than 1.5 secs without the call to admin-ajax.php. 1.5 secs is a very long time on the web.

    I will be using Etsy or Folksy rather than this plugin.

  16. Dugs
    Member
    Posted 2 months ago #

    closed

Reply

You must log in to post.

About this Plugin

About this Topic