WordPress.org

Ready to get started?Download WordPress

Forums

Confirm User Registration
[resolved] Admin account (11 posts)

  1. Djaouws
    Member
    Posted 4 months ago #

    I just downloaded and activate the plugin but i got a very bad issue!
    My admin account is locked out and need a conrfirmation by the administrator to login. Byt the user is a Authenticated user, why?

    http://wordpress.org/plugins/confirm-user-registration/

  2. Ralf Hortt
    Member
    Plugin Author

    Posted 4 months ago #

    Hi Djaouws,

    the plugin should confirm every login user when activated,
    please check your post meta database table for the meta key 'authentication' and your user id.

    If it is not present just add a row
    user_id = 'YOUR USER ID' ( prolly 1 )
    meta_key = 'authentication'
    meta_value = '1'

    What version of WordPress do you use and which version of the plugin?

    Cheers Ralf

  3. Djaouws
    Member
    Posted 4 months ago #

    Hi
    Thanks for a quick answer.

    I have WP 3.7.1
    amd CUR 2.1.1

    I have the meta key 'authentication' and it is set to 1.

    I think i solved it.
    In the username there is a @, when i replase the (at) with _ (undersore)i could login, and it's not an e-mail adress.

  4. Djaouws
    Member
    Posted 4 months ago #

    In the database/wp-user field user_login there is an @ but in the field user_nicename the @ was missing.

    i notice that a . (dot) is replace by a -(score).

    I guess the CUR use the user_nicename value and if it so i have several users who is locked out.

  5. Ralf Hortt
    Member
    Plugin Author

    Posted 4 months ago #

    Mmmh thanks for the hint…

    Seems like it is a WordPress problem with this code
    $user = get_users( array( 'search' => $user->user_login ) );

    Cheers Ralf

  6. Djaouws
    Member
    Posted 4 months ago #

    Maby a space in the user_login could be a problem too.

    I look forward to a solution.

    An excellent plugin I can't be without.

  7. Djaouws
    Member
    Posted 4 months ago #

    I have tested some more and it's only a @ who mess it up!
    Test with dot and space.

  8. Ralf Hortt
    Member
    Plugin Author

    Posted 4 months ago #

    Awesome thanks for the testing, I hope I can fix the bug, before I'll leave to New York!

  9. Djaouws
    Member
    Posted 4 months ago #

    Hi Ralf

    Do you have any progress to resolve the problem?

  10. Ralf Hortt
    Member
    Plugin Author

    Posted 4 months ago #

    Hello Djaouws,

    not yet as I'm just came back from New York, but I'll gonna fix this today.

    Cheers Ralf

  11. Ralf Hortt
    Member
    Plugin Author

    Posted 4 months ago #

    It is fixed now

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.