WordPress.org

Ready to get started?Download WordPress

Forums

Adjusting thumbnail size? (16 posts)

  1. Ramzii
    Member
    Posted 4 years ago #

    Hello, first of all, YOU ROCK!
    Danke schön das Schone thema. (:

    Now, Ive come a long way since the start.. and have learned a lot from your theme. Now I can somewhat read php-code and adjust it.
    Still tricky but I manage.

    Im almost done now translating every generic piece of info to my language, dont want any pre-written English on the site..

    Also planning on adding an automated javascript jQuery background slideshow, was wondering if that would be possible?

    And my main question/ only annoyance:

    The generated thumbnails, how do I change their dimensions?
    They look so stretched, and on the creators website they look so good!
    How does it work? Ive searched all the .php files atleast 5 times.. no luck there. What am I missing? Custom thumbnails would work too.. just tell me where to place the img link?

  2. IWEBIX
    Member
    Posted 4 years ago #

    Hi Ramzii,

    well the only thing which could be streched is the Slideshow on the Homepage.
    This is why Javascript doesn't let us have a generated thumbnail their.
    What you can do their is changing the dimensions of the image you would like to display to 400x220.
    Another solution would be adding another custom field only for the big image in the slider. Than you could upload a file that really fits the dimensions.

    Cheers

  3. StoarceCreierul
    Member
    Posted 4 years ago #

    Do you mean modifying some settings in the Dashboard - Settings - Media ?

  4. Ramzii
    Member
    Posted 4 years ago #

    Wait, Im not quite sure we are understanding eachother.
    Let me show you whats bothering me:

    http://img21.imageshack.us/img21/4961/33237722.png

    Another solution would be adding another custom field only for the big image in the slider. Than you could upload a file that really fits the dimensions.

    Now, I think/hope I can add a custom field just for the ugly thumbnail??

    If so.. could you write up in a few steps what to do and in what php file?

    If not, the solution would be to add one custom field for the BIG pretty picture. And post the thumbnail picture @ the existing "Featured" field?
    It this correct?

    Vielen dank.

    ps - I read somewhere that you are working on a new theme? Care to give us a preview? hehe

  5. Ramzii
    Member
    Posted 4 years ago #

    And I just took a look at Dashboard - Settings - Media .. haha didnt even know those setting existed.

    But no, I dont mean those thumbnails, I mean the thumbnails that are created through the javascript slider.js inside the folder wp-content/themes/wp-creativix/scripts.

  6. StoarceCreierul
    Member
    Posted 4 years ago #

    Alright, I got it... I saw this before and sadly I don't know how to improve it.

    Find a template that does the thumbnail stretching near the parameters you want and search those scripts to see how they did it.

  7. Ramzii
    Member
    Posted 4 years ago #

    Aw, im a relative beginner so im not quite sure that will work out.
    Im sure there is an easier way.

    Im not quite sure yet how, but if you look at the thumnails here:

    http://creativix.iwebix.de/

    They are cut off !

    That would be a huge improvement, compared to this:
    http://img21.imageshack.us/img21/4961/33237722.png

    Could you share that method IWEBIX? Danke

  8. IWEBIX
    Member
    Posted 4 years ago #

    Hi,
    this is a workaround for those who have not set correct permissions to the wp-creativix folder. You have to give proper permissions such as 755 or 777 to the wp-creativix folder and it's subfolders.
    If you don't set correct permissions thumbnails won't be generated, that why they are looking ugly (:

    Cheers

  9. Ramzii
    Member
    Posted 4 years ago #

    Hello IWEB, that did not work, this is what i get when i give the entire folder 755 or 777:

    http://img186.imageshack.us/img186/2271/77440924.jpg

    :(

  10. Ramzii
    Member
    Posted 4 years ago #

    I finally found how to adjust the ugly cropping!

    In order to adjust the sizes of the thumbnails you need to find the following file: index.php

    Its located @ /wp-content/themes/wp-creativix/

    Open it in notepad and adjust the sizes in all theses lines:

    "><img src="<?php bloginfo('template_directory'); ?>/scripts/timthumb.php?src=<?php bloginfo('template_directory'); ?>/images/add-feat.jpg&h=75&w=150&zc=1" alt="">

    This code results in:

    http://img521.imageshack.us/img521/2461/85525209.png

  11. Christine Jocelyn
    Member
    Posted 4 years ago #

    Ramzii please explain this to me ! I am very, very new to this and have no idea what you are talking about. My thumbnails will also not show up ! Do I go to "apperance" than "edit" than go to a certain folder? Will you PLEASE explain this in detail.

    My site: http://www.usmomssite.com

  12. Christine Jocelyn
    Member
    Posted 4 years ago #

    It shows this in one of the edit pages and i know i need to fix it:

    <span style="float: left; margin-left: 300px; margin-top: 300px; background-color: #c03725; color: #FFF; padding: 5px;">Thumbnails not working - Please give write permission to Theme (wp-Creativix) Folder (755 or 777)</span>

    HOW?!

  13. Christine Jocelyn
    Member
    Posted 4 years ago #

    And this:

    <span style="clear: both; margin-bottom: 10px; float: left; background-color: #c03725; color: #FFF; padding: 5px;">You cannot upload images because the folder "wp-content/themes/wp-creativix/images/logos/ is not writeable please CHMOD this folder to 755 or 777</span>

  14. Christine Jocelyn
    Member
    Posted 4 years ago #

    Alright, I know I am a huge bug. I just wanted to make sure that I did not waste your time as I figured out how to change the permissions. Now though, it still did not work. I also changed the thumbnail size like you explained and it also did not work.

    Thank you anyways

  15. Agrou42
    Member
    Posted 4 years ago #

    Hi,

    I have the opposite problem, my thumbnails are correctly sized but the big pictures are deformed.

    I think the rights of the theme folder are ok, I've chmoded it with 777 and also tried with 755 :
    wp-content/themes/wp-creativix-fr$ ls -la
    total 164
    drwxrwxrwx 4 root root 4096 jun 11 17:49 .
    drwxrwxrwx 7 root root 4096 jun 14 09:41 ..
    -rwxrwxrwx 1 root root 1071 fév 25 19:15 404.php
    -rwxrwxrwx 1 root root 1509 fév 25 19:15 archive.php
    -rwxrwxrwx 1 root root 3124 fév 25 19:15 comments.php
    -rwxrwxrwx 1 root root 949 fév 25 19:15 footer.php
    [...]

    In appearance/theme setting in wordpress I get this error :
    Thumbnails not working - Please give write permission to Theme (wp-creativix) Folder (755)
    So I don't understand where is the problem.

    Thank you for your help.

  16. kalico
    Member
    Posted 3 years ago #

    I would like to mention that the actual image size for the "Featured" image on the front page is actually 440 x 220.

    A comment from the developer above states "What you can do their is changing the dimensions of the image you would like to display to 400x220." That may have been true at the time, but the version I just downloaded has it at 440 x 220. My images were being stretched just slightly, so I measured with JR Screen Ruler.

    HTH

Topic Closed

This topic has been closed to new replies.

About this Topic