WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddThis
[resolved] AddThis 2.3 Plugin works with WP 2.8.6 but... (2 posts)

  1. mrlerch
    Member
    Posted 2 years ago #

    Just wanted to let you know that if you have the issue that your server does not support PHP 5.x or but runs on 4.4.x... There is a way to use WP. Use version 2.8.6, and you can use the AddThis 2.3 plugin also, but an important function is missing. The name of the function required is:

    sanitize_text_field

    This function can be found in wordpress/wp-includes/formatting.php in WP version 3.1.4 on line 2857. Copy the entire function and then paste it at the end before the ?> tag in the 2.8.6 version of formatting.php. Done.

    Also if your version of 4.4.x does not run Json you will have to install it via Pear and Pecl. Here are some basic instructions. Requirements are PHP-Devel, Pear and GCC:

    Type this into your terminal app
    sudo pear install pecl/json

    This should download and install json 1.2.1 and install it.

    Now you have to find your php.ini file and add the following line:
    extension=json.so

    Then restart Apache

    Hope that this will help some of you.

    Martin

    http://wordpress.org/extend/plugins/addthis/

  2. _mjk_
    AddThis Samurai
    Plugin Author

    Posted 1 year ago #

    Thanks, Martin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic