WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Addings new sites and routing parked domains (7 posts)

  1. wednesdei
    Member
    Posted 3 years ago #

    Evening,

    I've got the latest version of WP installed(3.0.2) with the domains mapping plugin setup. I'm attempting to get another domain added to my network. Heres what I am doing:

    1. Latest version of WP and MU domain mapping plugin installed with new sites as sub domains EG: http://myexample.example.com(Also have wildcard sub domain setup)
    2. Create new site which is setup at http://myexample2.example.com
    3. Everything works, I can navigate to that sub domain no problem, see wordpress going full steam
    4. Forward my domain name servers to my root domain name servers
    5. Setup the domain mapping plugin to associate site ID 2 with http://myexample2.example.com
    6. Attempt to visit myexample2.com and am redirected to http://www.example.com/ not http://example2.example.com

    Am I misunderstanding how multisite and the domain mapping is supposed to work? How do I get it setup so that when I visit example2.com I am forwarded to the subdomain site, not the root.

    Thanks and regards,
    Me

  2. wednesdei
    Member
    Posted 3 years ago #

    Also, I parked the domain via cpanel with no redirect, do I need a redirect?

  3. wednesdei
    Member
    Posted 3 years ago #

    Ok, so I am playing around and after disabling all my plugins and reinstalling the sunrise and domain mapping plugin I had some success. What is happening now is the following:

    I have a domain i want to add example2.com
    my main site is at http://www.example.com
    I create the site, park the domain, map it via the plugin and set example2.com as primary.

    If I visit example2.com I can see the version of wordpress i've installed, but it is now at example2.example.com it is at example2.com is this how it is supposed to work? I don't mind or anything, looks like it works fine just trying to understand what exactly i did...

    If I'm understanding correctly wordpress is using example2.example.com to pull the content from and via some trickery my browser is at example2.com but still connected to my network?

  4. Go to the admin area of example2.example.com to the tools -> Domain Mapping menu.

    Set example2.com as the *primary* domain for that site. otherwise, it won;t change the address.

  5. wednesdei
    Member
    Posted 3 years ago #

    Hello Andrea_r,

    so right now i have the domain mapping plugin going to site ID 2 with example2.com as primary.

    When I visit http://www.example2.com it changes it to http://example2.com

    If I set site ID 2 to map to http://www.example2.com it sends me to the main site of my install, not to the site that I created.

    Is this normal?

  6. Set your server to answer to the www version of the domain, and also - pick one to be the primary.

    yes, example2.com and http://www.example2.com are considered two different domains.

    (not just by wordpress, by everything but humans...)

    So you have to map the www version as well.

  7. wednesdei
    Member
    Posted 3 years ago #

    Hey there Andrea_r,

    You were right, adding that second map was the key. Currently, everything is working amazing just like it should. Thanks alot for all of your help.

    Me

Topic Closed

This topic has been closed to new replies.

About this Topic