WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] adding php to custom index makes some of my footer disappear! (4 posts)

  1. SavageAmber
    Member
    Posted 4 years ago #

    Hey guys,

    I'm customizing my homepage by making a page template.

    As soon as I add php to the new page template, some of my footer disappears.

    I'm using the berita theme, my current homepage can be found here:

    http://amberseree.com

    My test homepage *with* php can be found here:

    http://amberseree.com/testing-homepage

    my test homepage *without* php can be found here:

    http://amberseree.com/newhome

    Here is an example of some php i'm using in the "middle column"

    http://pastebin.com/f65ad6c72

  2. You've got all kinds of missing tags that are affecting the footer and page display: [Invalid] Markup Validation of amberseree.com/testing-homepage - W3C Markup Validator. Scroll down in the validation report for line numbers in the code listing. Compare your template edits with a fresh copy of your theme file(s).

  3. SavageAmber
    Member
    Posted 4 years ago #

    thanks for the reply, I was afraid no one would reply! I've tried that. I've gone through the validation, but none of it seems relevant. It's only the php thats effecting the footer. I've gone through edits, and I only took one line of code away from the original index, (calling an include). Is my php invalid? How do I know. I feel like a rookie! :)

    If i strip the php away it works fine, as soon as I add php it disappears.

    Do I have to add additional functions to include loops in the theme?

    I'm going to do more trouble shooting (3 hours now?) but if there are suggestions out there, it'd be much appreciated.

    thanks!

  4. SavageAmber
    Member
    Posted 4 years ago #

    figured it out!

    Had to start a new query : $my_query = new WP_Query

Topic Closed

This topic has been closed to new replies.

About this Topic