WordPress.org

Ready to get started?Download WordPress

Forums

Adding Pages Not Working? (25 posts)

  1. Sykil
    Member
    Posted 9 years ago #

    I upgraded to 1.5 and was excited about the pages feature, but it doesn't seem to work. I have friends with WordPress who can get it to work just fine.

    Basically, I go to Write Pages, make up some stuff to put there (tried making an about page), subimt, visit the URL (my_site/about), and it doesn't work. Any ideas on what to do? Could it be my mod_rewrite settings?

  2. Nick Momrik
    Member
    Posted 9 years ago #

    Yes, if you don't have your .htaccess file set to update automatically, you'll need to copy the new rewrite rules each time you create a new page and update .htaccess accordingly.

  3. Sykil
    Member
    Posted 9 years ago #

    Ok, thank you. I thought so, because I could manually enter the page_id in a query string and it would work.

  4. Nick Momrik
    Member
    Posted 9 years ago #

    If it interests you, with 1.5, WordPress can change your .htaccess for you. You simply need to make the file writeable by the server. Then you wouldn't need to do it manually each time.

  5. tmerritt
    Member
    Posted 9 years ago #

    I've tried adding new Pages - links show up on the main blog page - http://www.mysite.com/NewPage, but the new pages 404. I've just changed permissions on the .htaccess file to 666, but the pages still 404. What's the next step I'm missing?

  6. tmerritt
    Member
    Posted 9 years ago #

    Jumped the gun with the last post - I went back and changed the permissions to 766 on htaccess and that worked, all the new pages show up properly.

    Also: the codex instructions and other similar posts are confusing. Example from the codex:

    You must chmod the .htaccess file to 666 to edit it with the WordPress template editor, but this is not recommended, since if you do that, any user of your blog, who can edit templates will be able to edit it. You can change the permissions to 660 to make it server-writable, which again will have the same limitation.
    For a newb to WP, PHP, and so on, this seems to send a mixed message: "Fix your problem by changing .htaccess permissions to 666, but you put your site's security (or at least its templates) at risk, so don't do it." Is a user somone who has posting priveleges, a visitor to the site, a commenter? Please, a little clarification. This kind of confusing language is pretty rare in the WP galaxy; I'm grateful for all the support posts, codex entries, and blogs that have helped me this far.

  7. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Please post a comment to that article's discussion page and hopefully someone will look into it. You can also post to the wp-docs Mailing List to ask for someone to clarify the article.

  8. RobCarr
    Member
    Posted 9 years ago #

    WP seemed to be working fine on the CrossOver Online! web site.

    This morning, I created a new page, and it won't show up. I went to edit the .htaccess file and it says I don't have permission to edit the file. It won't let me edit any file that I've tried.

    I'm guessing I've got a bigger problem than just not being able to post a new page. Any idea on what caused this and how to fix it?

    I'm supposed to be the only one with access to the site.

    The site itself (with the exception of the new page I tried to add) seems to work fine.

  9. RobCarr
    Member
    Posted 9 years ago #

    Uh, never mind.

    For some reason, the change in permission to .htaccess didn't stick - when I tried it again, it fixed everything.

  10. pfleming
    Member
    Posted 9 years ago #

    Rob,
    Setting 666 on any folder is extremely dangerous, don't do it if you can at all help it. 666 is the attributes expressed in a numerical format, but essentially it means, 6-- owner of the file can read and write (write also means delete!) -6- those in the users group can read and write --6 everyone else (the whole world, more specifically others) can read and write the file.
    4 = read
    2 = write
    1 = execute
    If you want to set read and write it's 4+2 = 6, if it's read, write and execute it's 4+2+1 = 7. Read and execute is the highest that anyone you don't trust should be allowed eg 4+1 = 5. However, on a web server it is not the actual "other" group that has anything to do with the files. I set mine to 755 with the user and the group set to my username. If the server *must* write to a file, I change the group to the name of the web server group, in my case apache and change permissions to 765 or something along those lines.
    Long story short, if you do change permissions on those files as recommended, change them back as soon as they are written.

  11. indigowhite
    Member
    Posted 9 years ago #

    I've changed the permission to the wordpress directory (cmhod -R 777) and .htaccess file (chmod 666 .htaccess). Then WordPress automatically updated .htaccess for me. Nice!

    But my WordPress still can't make any Pages for me. All I get is a 404 Not Found error message. Anyone got a clue?

  12. indigowhite
    Member
    Posted 9 years ago #

    Could it be that I might now have mod_rewrite installed?

  13. indigowhite
    Member
    Posted 9 years ago #

    For future readers. Ok, I solved the problem myself.

    My server didn't load the .htaccess info, even thou i had mod_rewrite loaded

    I edited my http.conf file and changed AllowOverride variable to All instead of none. Violá!

  14. fro
    Member
    Posted 9 years ago #

    how do you edit the http.conf file?

  15. TomSmit
    Member
    Posted 9 years ago #

    I have the same problem - new pages get a 404. My .htaccess file is writable but I still get 404s. What do I have to do?

  16. TomSmit
    Member
    Posted 9 years ago #

    Help. Me. Now. Please!

  17. TomSmit
    Member
    Posted 9 years ago #

    What do I have to do? This is getting under my skin.

  18. fro
    Member
    Posted 9 years ago #

    I know if you put index.php in front of
    /%year%/%monthnum%/%day%/%postname%/

    so it says
    /index.php/%year%/%monthnum%/%day%/%postname%/

    it works ok. But I don't want to do that, because google doesn't list me on there site very well like that

    so... how do I edit the http.conf?

  19. TomSmit
    Member
    Posted 9 years ago #

    Unless you have a dedicated server or your host is willing you cannot edit http.conf.

  20. minou30
    Member
    Posted 9 years ago #

    I am not able to create new pages and DO NOT HAVE A .htaccess file in my word press directory???? Where is this file located? Thank you.

  21. KSA213755
    Member
    Posted 9 years ago #

    I've been experiencing the same problem, but it's not limited to pages, but posts as well. The new posts show up on the index page, but the links for the posts result in 404. Pages always get 404 errors. I changed my .htaccess file to 766 to test that out, and it didn't help. What else should I be looking at?

  22. KSA213755
    Member
    Posted 9 years ago #

    I also tried the "apache" solution posted by podz in the ".htaccess not updating thread". That didn't fix the problem either.

  23. tmerritt
    Member
    Posted 8 years ago #

    This probmlem still happens to me. I've changed the permissions to 666, to 766, to 777, all with Fetch, and still my new Page doesn't appear... 404, 404, 404. I know the page host runs Apache - please help a newb with this. Thanks.

  24. loveberryy
    Member
    Posted 8 years ago #

    I still can't change anything with all this help.

  25. tmerritt
    Member
    Posted 8 years ago #

    I finally found a fix that worked: changing the vars.php file in the wp-admin directory as instructed here in the codex:

    http://codex.wordpress.org/Using_Permalinks#Fixing_.28.htaccess.29_Generation_Issues

    I changed it via CPanel on my hosting page, not through the WP Admin > Manage > Files page, which still tells me If this file was writable you could edit it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.