WordPress.org

Ready to get started?Download WordPress

Forums

Adding background image... (3 posts)

  1. mah
    Member
    Posted 7 years ago #

    I've tried adding a background image to my theme, and even though the code is there, it is NOT appearing visually.

    what am I doing wrong? here is the code:
    #page { background-color: black; background-image: url("images/wallpaper.gif");...}

    I've tried to change it using the Theme Editor in the Main Index Template AND Stylesheet...are there other places I should edit the code as well to make it work?!

    Stumped.

  2. rgracia
    Member
    Posted 7 years ago #

    I normally add the background image to my page using the BODY tag on the CSS file. That is if I want the whole page to have that image as a background. Normally this is done if you want to use a web-unsafe color as bg and your browser refuses to display it correctly. Now, if you are applying a id #page to a div, then is not until you actually apply it by editing the div tag say <div id="page" - etc. that the image will display. Please note that editing the body tag will apply those settings to the entire page not the table or div where the content displays. Hope I sound clear.

  3. moshu
    Member
    Posted 7 years ago #

    Hope I sound clear.

    I am afraid you don't.
    In every second theme (read: kubrick clones) there is a "page " div right after the body. People are struggling with that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags