WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Adding A Site garbles and stutters the url (5 posts)

  1. malcs_64
    Member
    Posted 3 years ago #

    I'm trying to figure out why when Adding A Site, say the new site will be called "test", as in tld.com/test, it ends up being
    http://tld.comtld_comtest

    Any idea what's causing that and how to fix it?

  2. denniskempin
    Member
    Posted 3 years ago #

    I have the same problem.
    If I enter "[http://network.denniskempin.com/]test" as Site Address I will end up getting a new site with the following info:

    Domain: [http://]network.denniskempin.com
    Path: network_denniskempin_comtest/
    Home/Siteurl: http://network.denniskempin.comnetwork_denniskempin_comtest/

    This does not seem right, and obviously also does not work.
    You can correct this though by setting the Path to /test/.

    Any configuration errors? I will "attach" the important part of the wp-config.php.

    Thanks!
    Dennis


    define('WP_ALLOW_MULTISITE', true);

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'network.denniskempin.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

  3. You're both on Dreamhost and used the One-Click installer they have. that's my psychic guess.

    It stuffs a $base value with your db name in there at the bottom of wp-config.php which conflicts with the $base value that WP uses.

    Find it, remove it.

  4. denniskempin
    Member
    Posted 3 years ago #

    Your psychic powers are impressive, that's absolutely right. For me it fixed the error, thank you very much!

  5. malcs_64
    Member
    Posted 3 years ago #

    Yes, thanks for the tip, Andrea. All's well now.

Topic Closed

This topic has been closed to new replies.

About this Topic