WordPress.org

Ready to get started?Download WordPress

Forums

Added slash to image tags when editing? Page issues? (12 posts)

  1. truelight
    Member
    Posted 9 years ago #

    Okay I really did try to figure this out and maybe ya'll are going to think I'm crazy if it turns out be something dumb on my part--but here's the thing. I love to put smilies in my posts, and I have a huge collection of them I pull from a folder on another of my sites. I use html to link these but when I go to edit a post it changes the html to add a / at the end of the code...for example if the image and the end of the code was

    smile.gif>

    It would rewrite the code to say smile.gif />

    So of course with it like that none of the smilies will work. The only thing I have figured out to edit them properly is to put quotes around my http command--this is when I EDIT mind you. If I just delete the slashes and then try to save the file it will always come to a page not found error.

    I don't know if it's a plugin or one I need or if I am just doing it wrong or what but I am having a time of this! It puts the same slashes on my break commands and other commands too, and it doesn't matter because it all works fine as long as I don't have to edit...but once I have to edit everything is messed up.

    I would appreciate any help you can offer. I moved my journal over from a greymatter platform because I really love this software--I thought maybe it was only happening to the greymatter entries but I made my first new entry today and then went to edit it and it did the same thing.

    I appreciate any help!
    Blessings!
    Susie

  2. truelight
    Member
    Posted 9 years ago #

    Oh and I have a fresh install of 1.5, the plugins I am currently using are:

    Weather Icon
    Bad Behavior
    Get Recent Comments
    Markdown
    Referrer Bouncer
    Spam Karma
    & Verse of the Day

    It did it before I installed all of the newer ones though.

    And finally, the url to my site is http://www.stillbecoming.us

    If it would be helpful to have more info please let me know. I appreciate your help!

  3. Joshua Sigar
    Member
    Posted 9 years ago #

    The only thing I have figured out to edit them properly is to put quotes around my http command
    You mean instead of A you'll have B?
    A. <img src=http://img.gif />
    B. <img src="http://img.gif" />

    B is the correct format. You do need the quotes and slash. Wondered if that wouldn't load the image properly.

    Anyhow, if you still want to do it your old way, try unsetting the option "WordPress should correct invalidly nested XHTML automatically" in Options->Writing. I don't know exactly that the option is relevant, but won't hurt to try.

  4. truelight
    Member
    Posted 9 years ago #

    Well, actually I mean I would originally have this in my blog:

    <img src=http://www.whatever.com/image.gif>

    And then when I would go to edit that it would be changed to this:

    <img src=http://www.whatever.com/image.gif /> which would show a broken image on my entry.

    Then if I just tried to erase the extra slash, it would take me to a page not found error page and not change the text. The only way I can get the text to actually change is to erase the slash and put quotes (and yes I know that's proper html...but I was lazy typing lol) SO...However, IF I go back to edit the post after this then the entry looks like this:

    <img src="http://www.whatever.com/image.gif" /> So the problem just happens over and over again. Very frustrating lol

    It happens even if the quotes are there.

    I will try clicking off your suggestion alphaoide and report back on what happens! Thanks for the suggestion!

    Blessings!
    Susie

  5. ColdForged
    Member
    Posted 9 years ago #

    truelight, that's actually entirely valid XHTML. Since there's no closing </img> tag, the included closing slash is in the initial tag. The only problem comes when you incorrectly don't put quotes in around your source.

  6. truelight
    Member
    Posted 9 years ago #

    Well, I am still getting the error when I try to save the page:

    The page cannot be displayed
    The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

    However, the changes are taking and so far no added slashes! I think you might have fixed it for me alphaoide!! Thanks!!!!

    Susie

  7. moshu
    Member
    Posted 9 years ago #

    Since WP (at least in its original form) is valid XHTML that's the correct way to be coded, with slahes. Yes :)
    Reading: http://www.w3schools.com/xhtml/xhtml_html.asp - bottom of the page.

  8. truelight
    Member
    Posted 9 years ago #

    Thanks Cold Forged, the thing that was happening though is that no matter what, even with the quotes, the images would appear broken, and would only appear normally when the slash was removed. I hope that makes sense. Turning off the XHTML validator seems to have fixed the problem (though not with the page cannot be displayed error, but I really think they are one and the same).

    Could you give me a sample of the completely proper and complete tags for an image in my blog? Maybe I can learn *giggle* lol

    Blessings!
    Susie

  9. truelight
    Member
    Posted 9 years ago #

    oops double post...I apologize!

  10. truelight
    Member
    Posted 9 years ago #

    I'm reading your link Moshu--and laughing...I am a self admitted sloppy html writer. That's so wrong isn't it? I guess I'll have to clean up my act and learn to do better. I have a feeling I have found only a temporary fix here!

    Blessings!
    Susie

  11. truelight
    Member
    Posted 9 years ago #

    Okay I do have one question...if the code was correct as this:

    <img src="http://www.whatever.com/smilie.gif" />

    Why was I still getting broken images and then they would be fixed after I took the slash out?

    Could it be a browser issue?

    Blessings!
    Susie

  12. ColdForged
    Member
    Posted 9 years ago #

    Unsure, Susie. Perhaps it was a browser cache issue. Rest assured, the way you just listed is correct. For instance, on your site now the weather picture for mobile works just fine using that format.

Topic Closed

This topic has been closed to new replies.

About this Topic