WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Added a plugin, I think it caused a problem... (4 posts)

  1. msadventures
    Member
    Posted 8 years ago #

    The last change that I made to my site was to add google analytics. I put the javascript code in the header.php file of my theme, and I used semiologic's plugin for google analytics to activate it. Today, I go back to my site, and I can't get in to edit a post or add a new one or anything. I thought maybe the plugin did it, so I removed the javascript and deleted the plugin, but I'm still getting a page with the following errors whenever I try to get in to edit/add, can anyone help?

    Warning: main(): open_basedir restriction in effect. File(../wp-config.php) is not within the allowed path(s): (.) in D:\hshome\msadmich\msadventures.net\wp-admin\admin.php on line 5

    Warning: main(../wp-config.php): failed to open stream: Operation not permitted in D:\hshome\msadmich\msadventures.net\wp-admin\admin.php on line 5

    Fatal error: main(): Failed opening required '../wp-config.php' (include_path='.;c:\php4\pear') in D:\hshome\msadmich\msadventures.net\wp-admin\admin.php on line 5

    Everything was working fine before. I was just wondering if maybe the plugin had done something...my site runs off a windows server, and I haven't switched it over to Linux yet, even though I know I need to because some of the things I'd like to use develop errors because of the windows server. I've had this issue before, where for whatever reason, my sql server decided to add in code making it look like my D drive was part of a path or something, but I fixed that ages ago.

    Ok, I'm babbling now, sorry.
    Anyway, does anyone have any input? Thanks. :)

  2. msadventures
    Member
    Posted 8 years ago #

    Still not fixed, I've looked though MySql, trying to figure out where/why those errors are occurring, but no luck.

    Anyone? Bueller?

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 8 years ago #

    "open_basedir" is a PHP restriction that prevents it from accessing files in other directory trees. I don't think activating a plugin would be able to change this value on anything other than a temporary basis.

    If this is your server, check your PHP.INI and/or httpd.conf files for an open_basedir setting. Also look through your .htaccess files. Turn it off or set it to none.

    If this is not your server, talk to your webhost about it, only they can fix it, probably.

  4. msadventures
    Member
    Posted 8 years ago #

    It's fixed! I did have to contact my host, they took care of it. Thanks! :)

Topic Closed

This topic has been closed to new replies.

About this Topic