WordPress.org

Ready to get started?Download WordPress

Forums

Add sub-folder to permalink url (6 posts)

  1. Mishiwinks
    Member
    Posted 1 year ago #

    Hi,

    My default permalink is set to http://www.knitfocused.com but my wordpress is located in the sub-folder http://www.knitfocused.com/blog

    The problem is, every time you click on a link, it leaves out the "blog" in the url and goes to the main page. Where can I add blog into the permalink address?

    I tried to do this in the permalinks page and when I choose custom and save, it doesn't work. I tried to add it to the bottom under category and tag base and nothing works.

    Any help would be greatly appreciated!

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    This is not done with permalinks, see:

    http://codex.wordpress.org/Moving_WordPress

  3. Mishiwinks
    Member
    Posted 1 year ago #

    Thanks for the suggestion...I read the article you sent and the thing is...I never changed the folder or url for the site. It is in the same folder as the original installation.

    However, I did do the search and replace and it didn't work. The links/comments/etc are still using http://www.knitfocused.com/ instead of http://www.knitfocused.com/blog/

    I thought it was permalinks because when you look at them, it shows to use the default of http://knitfocused.com/archives/123 or http://knitfocused.com/?p=123 None of them have the blog/ folder in them.

    What am I missing. Seems like it would be such a simple fix.

    Thanks for your help.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Is /blog included on both URLs in settings->general?

  5. Mishiwinks
    Member
    Posted 1 year ago #

    Holy crap! That was it Rev! I knew it was something so simple. Duh! Thank you so much!!!! You are my hero <3

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    I'm glad it was an easy fix!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.