WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Add Scrolling (29 posts)

  1. Rookie999
    Member
    Posted 1 year ago #

    Is there a way to add scrolling so that the fancybox can scroll inside iteself when there is more content in the post to fit in, say 600px height?

    Thanks in advance. I love this plugin!! Defiant donor.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Rookie999,

    It depends on what kind of content you are showing in FancyBox.

    Try the dev version from http://wordpress.org/extend/plugins/easy-fancybox/developers/ which has a new option for iFrame that allows scrolling.

    Inline and PDF content types should already be scrollable by default.

    All other media content types (images, video, flash) will always fit exactly inside the FancyBox frame without scolling, whatever options you choose...

  3. Rookie999
    Member
    Posted 1 year ago #

    I added scrolling with a solution you gave:

    <div id="fancyboxID_1" style="width:460px;height:380px;overflow-x:hidden;overflow-y:scroll;"> ... </div>

    HOWEVER, when I hover over the content the mouse wheel will not scroll content. The only way to scroll is by clicking the bar and dragging. Is there something in the code I can change to fix this so the mouse will will allow it to scroll?

    Thanks,

    Thomas

  4. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    You could try changing the Center on scroll option on your Settings > Media admin page to see if that alters the scroll wheel capture behaviour. Or Maybe install the latest development version and disable the option 'Include the Mousewheel jQuery extension script to allow gallery browsing by mousewheel action.'

    But otherwise, I think you would have to hack the FancyBox jQuery extension script itself...

  5. taropaa
    Member
    Posted 1 year ago #

    I am trying to do the exact same thing!

  6. fastasleep
    Member
    Posted 10 months ago #

    Anyone find a fix for this? I can't trackpad/mouse scroll my content either, regardless of 'center on scroll' etc. Only way I can get it to scroll is clicking on the content then hitting the down arrow then grabbing the scrollbar while it's visible before it fades away again (FF/Safari). I've tried nested divs with overflow-y:scroll and everything I can think of.

  7. fastasleep
    Member
    Posted 10 months ago #

    I was able to solve my inability to get vertical scrolling working on a large div of text by renaming the jquery.mousewheel.js and jquery.mousewheel.pack.js files, essentially disabling them.

  8. RavanH
    Member
    Plugin Author

    Posted 10 months ago #

    Just disable the option 'Include the Mousewheel jQuery extension script to allow gallery browsing by mousewheel action.'

  9. fastasleep
    Member
    Posted 10 months ago #

    Ah, I see that shows up in the options for Images. I'm solely using the plugin for inline content so I didn't have that enabled. You might consider having that disabled by default if the user isn't using the Images option? Just a thought. Thanks!

  10. RavanH
    Member
    Plugin Author

    Posted 10 months ago #

    Good thought, and will consider :-)

  11. tszabo
    Member
    Posted 9 months ago #

    I'm also having this problem (cannot use mousewheel scrolling in inline content lightbox), and I've tried all the solutions in this thread and the related thread, but none of them fixed it. This included deleting .js files, enabling and disabling the mousewheel option under Images (it was already disabled), and others.

    Any other solutions?

    This is essential for us to use this plug-in.

    Thanks!

    I have v.1.5.5

  12. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    Hi tszabo, it might be that another plugin (or your theme) is adding the Mousewheel script to your site too. Can you share a link?

  13. tszabo
    Member
    Posted 9 months ago #

    Hi,

    Yes, I do use quite a few plug-ins, and the Headway theme framework.

    Link is at [worldwideweb].travelshak[dotcom]/destinations/big-island-hawaii/abc-stores The lightbox link is Package Details under the Beach Package on the right sidebar.

    Thanks,
    Tyler

  14. tszabo
    Member
    Posted 9 months ago #

    I just noticed that one of my other plug-ins (Headway's GalleryPlus photo slider) has a mousewheel function (wp-content/plugins/headway-galleryplus/js/jquery.mousewheel.min.js). I don't see a WP setting for their plug-in related to this.

    What's the solution?

    Thanks.

  15. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    Hi tszabo, could you try Easy FancyBox version 1.5.2? You can download it from http://wordpress.org/plugins/easy-fancybox/developers/ under Other Versions...

  16. tszabo
    Member
    Posted 9 months ago #

    Hi RavanH,

    I actually was able to delete the other plug-in mousewheel js file on my ftp, and now it works!

    I have a separate question now. When I scroll to the bottom of the lightbox, it then automatically scrolls the larger page behind it (and same if scroll to top of lightbox), even if the cursor is still in the lightbox. This is awkward and seems like a bug.

    Is there any setting to change this? If not, any plans to fix this soon in a new version?

    Thanks.

  17. tszabo
    Member
    Posted 9 months ago #

    RavanH,

    While deleting the mousewheel js file in the other plug-in fixed the problem, it caused a separate problem. When I test my page load speed with Pingdom, it shows that file as not being able to load, adding 2 seconds of waiting time to my page.

    Apparently, I did not properly delete the other mousewheel js file. Any advice please? If you tell me how to properly delete/deconflict, I could try seeing if I could restore that other file (not sure if it's too late).

    FYI, the other plug-in is Headway's GalleryPlus.

    Thanks.

  18. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    The problem is exactly the fact that you succesfully deleted the other file. You see, deleting the file while leaving the request in the page source code active, results in 404 pages getting generated for each request for this non-existant file. The visitors browser waits until it receives this 404 response before going on with rendering the rest of the page...

    What you can try is putting back the mousewheel script file that you deleted (download the headway gallery plugin zip file, open the zip and find the file in there, upload with FTP) and next go to the FancyBox options on Media > Settings. There you can find an option 'Include jQuery Mousewheel extension...' which you can uncheck. Save and test your site.

    The mousewheel script included by the headway gallery plugin will probably also work for FancyBox :)

  19. tszabo
    Member
    Posted 9 months ago #

    RavanH,

    I was able to reinstall the Headway plug-in to get it back working properly, but now FancyBox is once again not scrolling with the mouse.

    I had tried the setting solution that you mention (even though that box is already unchecked by default), and that does not work.

    Other suggestions please?

    Thanks.

  20. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    @tszabo a link to your site might tell me more...

  21. tszabo
    Member
    Posted 9 months ago #

    Sure. I had included it in earlier post above, but here it is again:

    Link is at [worldwideweb].travelshak[dotcom]/destinations/big-island-hawaii/abc-stores A lightbox (inline content) link is Package Details under the Beach Package on the right sidebar. There's also a lightbox (iFrame) used for Yelp reviews (on left), which appears to be scrolling fine.

    Thanks.

  22. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    Oh right, yes. Sorry. I see your point now. If you do not need mousewheel at all (even if it is included by the other plugin) then instead of removing it, you could replace that other mousewheel file by an empty one. But that really is just a work-around for the original issue.

    I'll be looking for a more permanent solution in the next release :)

  23. tszabo
    Member
    Posted 9 months ago #

    Ok, tried that. Created empty notepad file and renamed it the mousewheel js file (of the other plug-in), while renaming the original version .old. Unfortunately, scrolling still not working.

    So, to recap, scrolling only works when I deleted the mousewheel js file of the other plug-in, but that created a page load issue when my website tries loading this file (that no longer exists).

    If you have any other suggestions, please let me know. Otherwise, hopefully the next release will have the permanent solution.

    Thanks.

  24. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    Have you cleared your browser cache? It's probably using a cached mousewheel.js ...

  25. tszabo
    Member
    Posted 9 months ago #

    That was it -- thanks!

    Regarding my other somewhat related question, while the scrolling now works, when I scroll to the bottom of the lightbox and it reaches the end, it then automatically scrolls the larger page behind it (and same if scroll to top of lightbox), even if the cursor is still in the lightbox. This is awkward and seems like a bug.

    Any settings or fixes for this?

  26. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    The scrolling you see is just how most browsers work. First it scrolls content where the mouse is over, then the whole page. The same behaviour can be seen with form fields that have scolling or divs with overflow or iframes. Same goes for content presented in a lightbox...

    I might be able to 'catch' mousewheel action that happens outside the lightbox frame but I'll have to look into that. If I find a good work-around, it might make it into the next version :)

  27. tszabo
    Member
    Posted 9 months ago #

    RavanH,

    I checked out other webpages and their use of lightboxes, and it appears the difference is that their lightbox remains in a constant position while scrolling the main page behind it. With Easy FancyBox, on the other hand, the lightbox jumps around before adjusting back to the center of the page. This is awkward. If you haven't already, check out my webpage link in my previous post to see what I mean.

    Is there anyway to fix this so the lightbox remains in a constant position even when the page in the back is scrolling?

    I tried unchecking the "Center while scrolling" setting, but all this did was slow down the adjustment.

    If this is something that may be fixed in a future version, any estimate on timing would be appreciated, as I'm trying to figure out whether to look for another lightbox...

    Thanks.

  28. RavanH
    Member
    Plugin Author

    Posted 9 months ago #

    Ok, that jumpiness...

    Can you check http://www.status301.com/easy-fancybox-sandbox/ where the current development version is installed to see if you still get that jumping effect? If so, there is not much I can do about it. It's just the result of how the original FancyBox was built, I think...

  29. tszabo
    Member
    Posted 9 months ago #

    Yeah, it's jumpy on that site :-(

    I'll probably look for another lightbox plug-in, but thanks for all your responses/troubleshooting!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.