WordPress.org

Ready to get started?Download WordPress

Forums

add port number for connection type SSH2 (5 posts)

  1. drh2020
    Member
    Posted 1 year ago #

    For security reason we changed the default port number for SSH to something other than 22. Please consider adding an option to change the port number.
    URL location: http://<MYDOMAIN>/wp-admin/update-core.php?action=do-core-upgrade

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    As people installs normally with port 22, WordPress or any PHP-MySQL softwares, usually do not have the option. Its easier to troubleshoot it from serverside.

  3. jholder83864
    Member
    Posted 1 year ago #

    If you're being presented with that option, then it's likely there is a permissions issue that doesn't affect your site too often, but it causes wordpress to fall back to SFTP.

    Make sure the files are owned by the www user, then you'll be able to use PHP to upgrade as opposed to php->sftp.

  4. core-basic
    Blocked
    Posted 1 year ago #

    I agree with jholder. Sounds like a permission issue. Try to chmod the root or wordpress directory and give it more permissions.

    Remember to use the recursive command to affect all files and folders at once.

    chmod -R 775 /var/www/wordpress

    CHange the directory path to match your configuration and distro.

    I don't know why i assumed you were running Linux.. Sorry.

  5. wycks
    Member
    Posted 1 year ago #

    You can append your port number to your hostname under your SSH connection information.

    For example: http://www.example.com:14999

Topic Closed

This topic has been closed to new replies.

About this Topic