WordPress.org

Ready to get started?Download WordPress

Forums

Add Plugin page blank after upgrade to 3.9.1 (12 posts)

  1. carbfrze
    Member
    Posted 2 months ago #

    Hello all,
    I have updated my WordPress site from 3.6 to 3.9.1 twice now. Both times I have run into issues with the Admin menu not working. I have taken all of the normal steps of backing things up, resetting the theme to one of the defaults, disabling all plugins, as well as renaming the plugin's folder to pluginold and nothing has helped. I am starting a new thread as I have searched many existing ones and haven't found any answers. The site is http://ynp2.com

    Please help! I am trying to get this going for a client who wants full access to addition or removal of all content.

  2. Try manually resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

  3. carbfrze
    Member
    Posted 2 months ago #

    hello macmanx,
    I have done as instructed previously. But I went ahead and did all of these steps again and still not working. I can access the Installed Plugins and the Editor under Plugins. Just not the Add New.

  4. Ok, let's try the almost-nuclear option. Delete every plugin directory under /wp-content/plugins/ (but not the /plugins/ directory itself) and every theme directory except Twenty Fourteen under /wp-content/themes/ (but not the /themes/ directory itself).

  5. carbfrze
    Member
    Posted 2 months ago #

    Not sure if this makes a difference or not but there is no Twenty Fourteen theme under wp-content/themes/

  6. carbfrze
    Member
    Posted 2 months ago #

    Nevermind. I realized that when I did the manual upgrade I never copied over the twentyfourteen theme folder from the wp-content folder.

  7. carbfrze
    Member
    Posted 2 months ago #

    And now I have even more problems. After I uploaded the twenty fourteen folder, I cannot even access the Themese option under the Appearance tab

  8. carbfrze
    Member
    Posted 2 months ago #

    I removed the twentyfourteen theme folder and now I am able to access all Theme options again. And with the plugins folder completely emtpied as instructed, I am still experiencing the same issue. I can click on Installed Plugins and it states there are none installed and I can click on the Editor and it states the same thing. However the Add New still displays a blank screen.

  9. What themes do you have under there?

  10. Oh, sorry, reply above was late. Sounds like you have some huge problems, maybe an old or only partially updated copy of WordPress.

    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don't forget to delete the original files before replacing them.

  11. carbfrze
    Member
    Posted 2 months ago #

    Thanks for the reply but that is what I have already done to upgrade to 3.9.1 manually.

    I will probably just have to start from scratch on this one. I am taking this project over from a former coworker who enjoyed editing the you-know-what out of code manually and may have screwed something up within the wp-content that I am not aware of.

  12. Did you indeed delete the old files before uploading the new ones? As mentioned, "Some uploaders tend to be unreliable when overwriting files, so don't forget to delete the original files before replacing them."

Reply

You must log in to post.

About this Topic