WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Add on Domains and Bluehost (9 posts)

  1. blackdigit
    Member
    Posted 7 years ago #

    Hello,

    I currently have a hosting package with Bluehost. I bought another package for another domain and was on the phone with Bluehost on something else and they kindly suggested that I set up an add-on domain on the original package to save money and simplify things. So they set up the add-on and I went to install wordpress on that subdirectory.

    I downloaded wordpress, adjusted my wp-config file with new database and user info, put .htacces in the director, uploaded to server, got through to the installation utility and was given a login. All seemed good, but when I went to log in to the admin page, the page just refreshed. It seemed to like the password, but it wouldn't let me into wp-admin.

    Is there anything in particular I should do when installing to an add-on domain that I might have missed? Am I better off using another hosting package? Do I need to adjust something else in the config file with an add-on?

    Thanks.

  2. MichaelH
    Member
    Posted 7 years ago #

    Consider using phpMyAdmin to make sure your wp_options table has the correct values in siteurl and home.

    siteurl is your WordPress address (URI) and home is your Blog Address (URI).

    You might also need to change your password in phpMyAdmin Resetting_Your_Password#Through_phpMyAdmin

    Additional info:
    Options, General panel

    [edit] Don't know anything special you would have to do to install WordPress in an addon domain.

  3. blackdigit
    Member
    Posted 7 years ago #

    Michael,

    thanks for the reply.

    As for the first recommendation, should my site URL be http://www.domainname.com or should it be http://www.domainname.com/addondomain.com ? I'm asking because the addondomain folder is in a subdirectory. Also, I don't see a home value in the database.

    I changed the password through PHPmyadmin but I still couldn't log in. It did the same thing as before: just refreshed the page.

    Thanks.

    I'm kind of a newbie, so I hope that makes sense.

  4. moshu
    Member
    Posted 7 years ago #

    There should be ONLY one domain in the site_url value - most likely your add-on domain.

    Look harder! The home value is also there: maybe on the next page. Look for the > sign at the bottom of the page!

  5. blackdigit
    Member
    Posted 7 years ago #

    moshu,

    Thanks. Found home. The wordpress address is the same as the blog address. Does that make sense? Should they be the same, especially considering that the blog is installed in a subdirectory?

  6. moshu
    Member
    Posted 7 years ago #

    In most cases they should be the same.
    A domain is NOT a subdirectory - even if you see it like that in your FTP client.

    I have had clients where 3-4 domians were hosted on the same account and when connecting via FTP they all looked like a "subfolder" but actually they all were independent domains!

  7. blackdigit
    Member
    Posted 7 years ago #

    Fixed it!

    Thanks so much for your help. Michael, thanks for pointing me in the right direction.

    On the general options page link Mike gave me I read:

    WordPress address (URI)
    Enter the address where your WordPress core files reside. It should include the http:// part too. If you have installed WordPress into a directory called "wordpress" on a server called "something.com", your blog's address might look something like: http://something.com/wordpress. Do not put a backslash "/" at the end.

    So, I changed the URI to reflect the subdirectory where my blog resides and everything worked out, and I was able to get into the wp-admin page.

  8. blackdigit
    Member
    Posted 7 years ago #

    ...
    I thought it was fixed, but I tried to enter the admin page again and it did what it did to cause me to come here in the first place. I don't know if changing the path on the wordpress uri is what fixed things but when I typed in http://www.domain.com/addondomain/wp-admin, typed in my password, it let me in. One or the other, or both, was the fix.

  9. blackdigit
    Member
    Posted 7 years ago #

    Moshu,

    Thanks for correcting my bad choice of words. I'm a newbie.
    Even though it looks like a subdirectory on my FTP client, it's a domain that was set up through cpanel. But it's located in a path the same way you would locate a subdirectory, so it's confusing to me.

Topic Closed

This topic has been closed to new replies.

About this Topic