WordPress.org

Ready to get started?Download WordPress

Forums

Add-on domain points to Primary domain address (8 posts)

  1. funkimon
    Member
    Posted 1 year ago #

    Hi
    I've managed to set up and get wordpress working on my Primary domain
    funkimon.com and have got an add on domain moshimarket.co.uk with wordpress installed and functioning correctly.
    But as soon as a page is clicked on moshimarket the address will change to where I have the folders on my hosting account.
    So in the address bar you will see funkimon.com/moshimarket/work-in-progress or whatever. I only want to display the moshi/work-in-progress address.
    Its hosted on bluehost and I have changed nameservers on the moshi address to point to theres
    Any help as simple as possible would be much appreciated thanks

  2. bhpress
    Member
    Posted 1 year ago #

    You will need to change your wp-url. You will want to change the default URL for the website when using WordPress's script.  This is configured when WordPress is installed. You can change this configuration in the database what the default URL is for your WordPress site.

      1)  In the cPanel, choose phpMyAdmin icon and, in left column, choose your WordPress *database.
      2)  Select the wp_options table on the left column.
      3)  Along the top, click the Browse tab.
      4)  There are two records to modify.  Record #1 (siteurl) and #39 (home) (these can vary, but unlikely).  For each, click the pencil icon to edit and change the option value to read the URL that you intend your links to display, such as http://domain.com.

    * = If you do not know the database's name, return to the cPanel and select the File Manager icon.  Navigate to the directory where the WordPress script is installed.  Select the 'wp-config.php' file and click the Edit button along the top to view the name.

    Also if you don't want it to display /wok-in-progress you will need to move it to just moshimarket. Here is a wordpress article on that:

    http://codex.wordpress.org/Moving_WordPress

  3. funkimon
    Member
    Posted 1 year ago #

    Hi thanks for your reply
    I followed all of your steps and it didnt work correctly.
    But I think there may be a problem with my install.
    i Had (siteurl) and (home) the wrong way round
    When I swapped them the site didnt work correctly but it still displayed the correct name which I want.
    I think the best thing to do maybe delete the folders and try to start over?

  4. bhpress
    Member
    Posted 1 year ago #

    If you don't' have to much work invested that would be my suggestion.

  5. funkimon
    Member
    Posted 1 year ago #

    Thanks I will reinstall over the weekend if there's still problems will post back. Thanks for your answers

  6. funkimon
    Member
    Posted 1 year ago #

    Thanks I will reinstall over the weekend if there's still problems will post back. Thanks for your answers

  7. funkimon
    Member
    Posted 1 year ago #

    Well can't fault my hosting company. I emailed them my problem they logged in and corrected it for me, excellent service, bluehost by the way, they said the url was incorrect in the wordpress install

  8. bhpress
    Member
    Posted 1 year ago #

    That is one reason why I am such a bluehost fan!

Topic Closed

This topic has been closed to new replies.

About this Topic