WordPress.org

Ready to get started?Download WordPress

Forums

Add Media - not working, asking me to login... (22 posts)

  1. WoodiE
    Member
    Posted 6 years ago #

    I just recently upgraded to WordPress 2.5 and when I try to upload an image via the "Add Media" within a page, my screen goes black loads the page in the center and I click on "Choose files to upload" which a dialog box asks me to pick which file(s) I want to upload.

    After making my selection to upload one .jpg image the new screen that comes up is "Crunching" then goes to a WordPress user/admin page login. I type in my admin login info and within the same small area my sites main pages loads.

    Any ideas as to why the Add Media is broken?

  2. WoodiE
    Member
    Posted 6 years ago #

    WordPress Support, anyone?

  3. worldview
    Member
    Posted 6 years ago #

    I don't even get that.

    I am trying to add a photo to a new post and I click on add media or the picture icon and the screen goes black and it asks if I am sure I want to do that and if I click go ahead and try again, a window of the write post window in it opens.

    mac os 10.5.2 (safari 3.012

  4. CircleReader
    Member
    Posted 6 years ago #

    I'm getting the same problem as WoodiE, using Windows XP & Firefox 2.0.0.13. It is very bizzare and dysfunctional. And of course it makes the new WP 2.5 Gallery features completely useless.

    I do not have the same problem on a local install with WOS (Webserver on a Stick). (Good thing, or I'd have little idea what I was supposed to expect.)

    I'm mystified - is there a file that has gone wrong, and needs to be replaced with an updated or uncorrupted version? If so, which one(s)?

  5. doggybag
    Member
    Posted 6 years ago #

    I just recently upgraded to WordPress 2.5 and when I try to upload an image via the "Add Media" within a page, my screen goes black loads the page in the center and I click on "Choose files to upload" which a dialog box asks me to pick which file(s) I want to upload.

    After making my selection to upload one .jpg image the new screen that comes up is "Crunching" then goes to a WordPress user/admin page login. I type in my admin login info and within the same small area my sites main pages loads.

    same problem ... I am on firefox 2.0.0.8 and Win XP

    I have deleted all files, reloaded complete 2.5 from wordpress .. reuploaded to server. Deleted cache twice .. rebooted ... waited a day and then did the whole thing all over again ...still the same problem - After making my selection to upload one .jpg image the new screen that comes up is "Crunching" then goes to a WordPress user/admin page login

    ciao
    db

    P.S I have disabled all plugins and reverted to wordpress default theme

  6. boerbramer
    Member
    Posted 6 years ago #

    I have exactly the same problem with FF 2.0.0.11

  7. boerbramer
    Member
    Posted 6 years ago #

    Problem is gone. Probably a Flash upgrade, I guess

  8. CircleReader
    Member
    Posted 6 years ago #

    Still getting the problem, and I have the latest version of Flash.

  9. CircleReader
    Member
    Posted 6 years ago #

    My host James at Freshly Pressed writes:

    Added the following to your .htaccess and it seems to have fixed your site problem...

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
  10. techguy
    Member
    Posted 6 years ago #

    I'm having this same problem. I've tried everything on this list http://wordpress.org/support/topic/164999?replies=1

    I've also tried everything in this thread (which is basically redundant for the list I linked to). Any other ideas of things I can try? My wife will love me if I can get this fixed.

  11. dester
    Member
    Posted 5 years ago #

    Come on WORDPRESS give us some help here. Please, please, please. SO many people are having this same problem with ADD MEDIA. A lot of us miss the ease of the old insert photo function. What gives? I click the file I want up load and then get the "CRUNCHING..." notice and thats as far as it gets. Hangs up until the cows come home. It stays there until my computer goes into sleep mode. PLEASE let us know how to fix this. Those of us that are photographers need this function ASAP.

    CIRCLE READER SAYS THIS -- and it's the only real help here but I have not idea what my .htaccess is...and where in that do I add this the code?

    CircleReader
    Member
    Posted 1 week ago #

    My host James at Freshly Pressed writes:

    Added the following to your .htaccess and it seems to have fixed your site problem...

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  12. CircleReader
    Member
    Posted 5 years ago #

    Hi, dester-
    What my tech guy did is listed as number eight on the fantastic list posted by crashutah, above. You should definitely work through that list.

    You can also try out this plugin: http://wordpress.org/extend/plugins/askapache-password-protect/, which will make the .htaccess file for you, and might just solve this problem, since the plugin authors have updated their plugin since becoming aware of it.

    I'll post a question on the thread for that plugin, since we need advice from honest-to-goodness coders who know more than I do about security for WordPress. ;)

  13. askapache
    Member
    Posted 5 years ago #

    Turning mod_security completely off for an upload script scares me. I had to do that for my plugin because most people don't have mod_security, but for those of you with mod_security you might want to consider some type of access control.

    Instead of

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Instead I would leave it on for everyone except me, and keep it on for everyone else. But actually if I was having this problem I would go and turn on debugging to find out the security rule causing this false positive and just fix that.

    <IfModule mod_security.c>
    <Files async-upload.php>
    SetEnvIfNoCase Remote_Addr ^208\.113\.183\.103$ MODSEC_ENABLE=Off
    </Files>
    </IfModule>

    While working on the AskApache Password Protect plugin I also had problems with the image media uploader. I found out that WordPress 2.5 is now using a small swfuploader.swf file which is a separate application than your browser. Javascript was my first guess but its definately connecting to your server from the flash application.

    Which isn't a bad thing, just some unfinished action-script programming for the flash developer. So sounds like you guys are having a different problem than a HTTP Basic authentication one, so my guess is the flash app is using some sort of suspicious looking request in its communication with the server.

    You can easily find out exactly what is triggering the mod_security rule by turning on logging. I blogged in some detail about how to do that on DreamHost.

  14. inetd
    Member
    Posted 5 years ago #

    Get **RID** of that Flash crap! It's nothing but trouble, believe me. If this is all WP can do after ver 2.5.x, then we've got to look elsewhere for the most basic of functions - picture uploads.

    We just need to:

    1) upload 1 or many pics
    2) resize them

    Now HOW difficult is that WP? I notice you guys have not replied to any of the hundreds of complaints about this FLASH based upload thing you've put into WP. If you're not going to fix it then let us know - deal?

    It certainly does not work now on IE, Opera, Safari or Firefox

  15. toritaiyo
    Member
    Posted 5 years ago #

    @inetd

    Was just about to say the same basically.
    The best suggestion on that page
    (http://wordpress.org/support/topic/164999?replies=1)
    mentioned above is at the end:

    Finally, if you simply want to give up entirely on the flash uploader for now, use this plugin to disable it: No-Flash-Uploader

    Did this and now it is working fine!!
    Thank goodness!
    why do it with Flash anyway? I don't get it...

    The .htaccess thing CircleReader mentioned worked too, but looks really unsafe so I deleted it and just went with the disable.

    Long story short,
    If you are having this problem with the Flash uploader, just DISABLE IT!

    and save yourself from :frusty:

  16. vizou
    Member
    Posted 5 years ago #

    Try logging in to your admin backend from

    http://yourdomain.com/subfolderifthereisone/wp-admin

    instead of with the popular

    wp-login.php or loginout links

    You may be surprised to see this issue go away... I have added this info elsewhere in the forums too; sorry I don't have that link to put here, but this issue has come up in other situations.

    I believe that some other folks found that changing themes (i.e. to default theme) and then back to theirs solved this issue as well, although I don't know why in either case.

  17. AlfietheCoder
    Member
    Posted 5 years ago #

    At last - the Disable Flash plugin has finally sorted this out. What a nightmare.

    Moral: don't use technology that doesn't work for everyone. WordPress is great, but this is v. frustrating!

  18. LeaseahB
    Member
    Posted 5 years ago #

    I had the same problem on a blog and nothing else in the list worked for me (even the .htaccess) except -- loading the No Flash Plugin worked!!

  19. inntell
    Member
    Posted 5 years ago #

    I could not upload images for a few day, hmongasia.com . But it's fixed right now, confirmed No Flash Plugin worked.

  20. ldexterldesign
    Member
    Posted 5 years ago #

    download this add-on and you're sorted: https://addons.mozilla.org/en-US/firefox/addon/433

  21. Freebord
    Member
    Posted 5 years ago #

    No flash plugin worked for me too in FFox 3. thank you!

  22. sfmobius
    Member
    Posted 5 years ago #

    I'm using a fresh install of v2.7 and a new database. Every time I uploaded an image I got the "auth required" box. After an exhaustive effort on the items above, none of them worked.

    However, I changed the upload directory and the problem disappeared. I only upload images/videos to my blog and I am the only person allowed to upload. Not sure if that works for everyone but putting it out there for anyone else, like me, who just wants it to frakin' work!

Topic Closed

This topic has been closed to new replies.

About this Topic