WordPress.org

Ready to get started?Download WordPress

Forums

Add Media Not Working (12 posts)

  1. mahabarbara
    Member
    Posted 1 year ago #

    I'm using WordPress 3.5, but this started with an earlier version. I cannot add media through the WordPress admin page. When I try to upload a file, I get this message:

    Unable to create directory uploads/2012/12. Is its parent directory writable by the server?

    I can add media if I upload an the media file into my webhost site and then add the link code manually. But that's a pain.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. mahabarbara
    Member
    Posted 1 year ago #

    Where do I do that? There's nothing with numbers like that in the domain.com/html/wp-content folder.

  4. nathancope
    Member
    Posted 1 year ago #

    In your FTP client this can be done, right click on the 'wp-content' folder and click 'File Permissions', then set the numeric value to one of the above!

  5. mahabarbara
    Member
    Posted 1 year ago #

    I have an FTP client? Where is it? I poked around on my webhost site and they don't seem to know what my FTP client is. Is it part of WordPress? If so, where is it?

    All I know is that the upload media thing used to work, and now it doesn't, and I haven't done anything but upgrade WordPress.

  6. You can download an FTP client. Here's more info about this - http://codex.wordpress.org/FTP_Clients

    Your webhost should know what FTP is and they should also be able to fix permission issues for you. If they don't know, I would find another host.

  7. mahabarbara
    Member
    Posted 1 year ago #

    Oh, they know what FTP is. My webhost has many articles about FTP, none of which I understand, and none of which say squat about changing permissions. I will ask them how to change permissions. I may download he FTP client also.

  8. Bill
    Member
    Posted 1 year ago #

    I wanted to add this bit of info in case anyone else with the same error message might be helped by it. Like many others, I scoured dozens of threads with multiple suggestions until something finally worked. Since this is one of the more recent threads, I'll drop it in here.

    This was the pre-populated file-path for media uploads found in my WP Settings > Media > upload path, probably from a previous WP version (or former hosting provider, more likely) because I had never specified this path: (example):

    /data/1/2/3/123/456789/user/123456/htdocs/blog/wp-content/uploads

    After getting sporadic permissions errors trying to upload to the uploads directory, I removed the above path and replaced it with the default wp-content/uploads path. This immediately fixed the problem, and the former settings field disappeared from the media settings page, further suggesting that it was legacy settings field.

    Anyway, I hope this helps somebody else with this problem. All the advice I'd seen about setting permissions to 777 was bad advice for an uploads directory, IMO.

  9. mahabarbara
    Member
    Posted 1 year ago #

    Bill -- thank you. At this point I'm pretty much resigned to doing without uploading media, because the FTP client I uploaded never worked, either, and I am terrified to start messing with code. It's going to have to stay broke. But if this is a frequent problem, maybe the WordPress techies ought to think of a way to fix it.

    You can see my media-challenged website at http://www.mahablog.com .

  10. Bill
    Member
    Posted 1 year ago #

    Barbara - sorry the fix didn't do it for you. Maybe it will for someone else?

    If you want to try esmi's advice above and temporarily adjust directory permissions (but without using an FTP client), you might try your web host's file manager. If your account uses cPanel, for example, you can change permissions via File Manager there (if your host allows it for your type of account). It isn't difficult. Don't forget to set it back though as esmi recommends, as you need to protect your site. Good luck.

  11. sdaris
    Member
    Posted 1 year ago #

    I have the same issue .. I can, through WP add media, add my images. I see them in the interface in WP and I see them in FTP.

    However it will not post as a single photo or as multiple photos as a gallery in the editor.

  12. sdaris
    Member
    Posted 1 year ago #

    I did find one plugin causing an issue.. Hana Flv Player
    I removed it and add media now works.

Topic Closed

This topic has been closed to new replies.

About this Topic