WordPress.org

Ready to get started?Download WordPress

Forums

Add Media - Insert Image in Post not working (45 posts)

  1. ejk
    Member
    Posted 5 years ago #

    I'm having the same problem: images upload fine, but clicking 'Insert Into Post' results in the white dialog box.

    I'm getting the following Javascript errors in the Firebug console:

    Permission denied to call method Location.toString
    http://whattheh.herald.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20080430
    Line 230

    Permission denied to get property Window.send_to_editor
    http://whattheh.herald.com/wp-admin/media-upload.php?type=image&tab=gallery&post_id=477
    Line 4

    Hope this can shed some light, it seems like a widespread problem.

  2. ejk
    Member
    Posted 5 years ago #

    I finally got it!

    Under Settings -> WordPress Address (URL), my domain name had mixed capitalization. Once I changed it to all lower-case, it started working.

    I found this solution in another thread, reposting in case it helps anyone:

    I found that my problem came with my WordPress address (URL) having uppercase letters, and apparently PHP does not like that. I suggest making sure that the URL is all lowercase. It fixed my site, who knows, it could fix yours.

  3. Prasad Thombre
    Member
    Posted 5 years ago #

    Just replace wp-admin\post-new.php and wp-admin\media-upload.php with the fresh ones. It helps me!

    http://www.myloverswish.com

  4. melissasue
    Member
    Posted 5 years ago #

    I just started having this problem after updating to 2.6.3 I click the add "image" button and instead of the usual inline little box that comes up, the entire page changes to the insert picture page and when you press insert into post, it doesn't even take you back to the page.

    I have downloaded and reuploaded the files again and I checked my Flash version -- it's 9.

    I'm not sure what else to do.

  5. thecreativepenn
    Member
    Posted 5 years ago #

    I got this error as well for 2.6.3 - after I propagated a new URL through the internet. You have to have the EXACT match of your website name in the command bar as is on the WordPress settings - General - WordPress Blog Address (URL) field - and it is case sensitive.
    I had http://www.TheCreativePenn.com in the field and actually it should have been http://www.thecreativepenn.com - when I changed it, everything works fine again.
    I hope that helps some people - I tried a whole load of other things first that were complicated - but it was this simple! so try this first and then try the re-installing etc etc.

  6. falfuly
    Member
    Posted 5 years ago #

    for me the problem was one of the plugins.
    once I deactivated wordpress-google-seo-positione the problem was solved

  7. fordy
    Member
    Posted 5 years ago #

    Plugin problem as well, I deactivated Position Yourself and everything is working. So check your plugins, and as suggested deactivate them one by one till you find the culprit and once you find it, go to the plugin developer and see if there is a fix for it.

  8. psm9640
    Member
    Posted 5 years ago #

    UN-FREAKIN-BELIEVABLE!!!!!

    Mixed-capitalization was the issue for me too (same as ejk mentioned!)...

    AHHHHHHRRRRGGGGGHHHHHH... at least it works now!!!:)

  9. websitehelper
    Member
    Posted 5 years ago #

    SOLUTION FOUND!!!!

    Problem: Could upload images but could not insert them into posts using the Upload/Insert Image. Got a white pop-up with an error message in the status bar. Latest error sited "permission" problem.

    Solution: I simply (although it took me 6 months to figure it out, off-and-on by combing through these forums) changed my blog URL to all lowercase, following someone's suggestions. Do this in "Settings/General" and this fixed it in IE and FF - the two places I tested it.

    I had tried everything and after 5 WordPress upgrades I knew that that was not the problem.

  10. James609
    Member
    Posted 5 years ago #

    Under Settings -> WordPress Address (URL), my domain name had mixed capitalization. Once I changed it to all lower-case, it started working.

    Worked for me. Thank you VERY much.

  11. omarmossadek
    Member
    Posted 5 years ago #

    The 'Position Yourself'(v1.2) plug-in was also the culprit for my WP-2.7.1 install.

  12. cliffeotc
    Member
    Posted 4 years ago #

    Under Settings -> WordPress Address (URL), my domain name had mixed capitalization. Once I changed it to all lower-case, it started working.

    WOW!! This was also my problem!

    THANK YOU THANK YOU THANK YOU!!!

  13. bayoujac
    Member
    Posted 4 years ago #

    Disabling all the plug-ins and reinstalling one-by-one proved to be the perfect solution!

    I found out that it was the plugin that allows you to put Amazon links into your posts... that disables the ability for the popup window to work in the admin.

  14. usagilbert
    Member
    Posted 4 years ago #

    I just started in the WordPress world. I had no problem with media uploading until I installed podPress plugin. Not only did it keep me from being able to use the media insert, it also distorted the size of my images in each post running them under the left and right side bars. As soon as I deactivated the plugin, the media insert worked fine, and the photos displayed properly.

    I need to add audio files to my site so a podcast plugin is very helpful. Anyone know of a more compatible plugin for this? (This is the first and only plugin I have used).

  15. dark0
    Member
    Posted 4 years ago #

    here is a good podcast plugin i used.
    http://wordpress.org/extend/plugins/podcasting/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags