WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Add Media dosen´t work - PHP Fatal error (4 posts)

  1. 1aus
    Member
    Posted 10 months ago #

    Once again - one more problems with this plugin.

    As described in the Title, the "ad media" button isn´t working anymore, you can choose the gallery and all of the pictures, the attemp fails and the blank media-window isn´t closing. The server logs shows folling error:

    PHP Fatal error: Call to a member function id() on a non-object in ... /nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/class.display_type_controller.php on line 210, referer: .../wp-admin/media-upload.php?type=file&tab=nextgen&chromeless=1&post_id=1638&select_gal=16

    The above mentioned lines in class.display_type_controller.php stats: "Returns the effect HTML code for the displayed gallery and param type $displayed_gallery"

    Any suggestions?

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 10 months ago #

    @1aus - We are working on this issue already and expect it to be resolved shortly but are currently focused on providing a stable release to address the issue with CRON jobs and transients first.

    Please feel free to watch this page for more details: http://www.nextgen-gallery.com/nextgen-gallery-latest-beta/

    Thanks!

    - Cais.

  3. 1aus
    Member
    Posted 10 months ago #

    Good to hear,

    the 2.0.25 svn is working without the above mentioned php error. On the other hand the 2.0.27 is again broken, whatever changed between this subversions.

    Greetings

  4. 1aus
    Member
    Posted 10 months ago #

    Thanks for the quick respond and the patch, Cais!
    I appreciate your work and effort realy.

    All, if you look for the solution look topic below.

    [resolved] Fatal error inserting single pic

Reply

You must log in to post.

About this Plugin

About this Topic