WordPress.org

Ready to get started?Download WordPress

Forums

add media - choose files to upload DIED (12 posts)

  1. Andrea333
    Member
    Posted 5 years ago #

    Has Firefox changed recently?

    Two days ago I was trying in IE and Firefox to upload some jpegs, it didn't work in either browser. (When I click Write, then on the Add Image button in the Add media toolbar above the text box, and click on Choose Files to upload, the button did nothing and the Windows file dialog box never opened.)

    I thought that maybe we uploaded too many images or some sort of buffer was full.

    I logged in as admin and changed the upload path for media from my previous folder name of "1" to "2".

    It worked for one computer in IE, but not the other.

    And today, it still doesn't work in Firefox.

    Am I missing something?

    Thanks for any insight you can provide.

  2. Limey2632
    Member
    Posted 5 years ago #

    This has happened to me too. It happened first in IE 7 an d now with the latest updates in Firefox I can not upload images through the upload feature of wordpress. As you said, it "died".

    Limey

  3. Andrea333
    Member
    Posted 5 years ago #

    Were you able to fix it? My "choose files to upload" button doesn't work in Firefox still. It just looks like it bounces when I want to use it, but no windows browse for file dialog opens.

  4. Andrea333
    Member
    Posted 5 years ago #

    Arggg. Well, even though I read the "sticky" for this forum, I didn't realize my Firefox or my co-workers' had been updated to Flash 10. This explains why it still works in IE on one or two computers (because they are still at 9).

    Here's a workaround:

    FIREFOX 3.0.4 with Flash 10:
    Tools > Add-ons.
    Plugins tab.
    Find Shockwave Flash in the list.
    Click Disable.
    Click the X to close the window.

    INTERNET EXPLORER 7 with Flash 10:
    Tools > Manage Add-ons > Enable or Disable Add-ons.
    (Be aware, there is a drop-down at the top of this window. It defaults to "currently loaded" stuff. You may need to go into the "have been used list" instead.)
    Find Shockwave Flash Object in the list and click to select it.
    Choose the Disable radio button.
    Click OK.

    This will change the way the button appears.

    I hope this helps someone else. I hope WordPress 2.8 comes out soon (they said Flash will be out then). This is a real pain for web designers.

    (p.s. My problem was also two-fold. I changed the upload folder from a 1 to a 2, but didn't change the permissions settings for the folder. That's fixed now.)

  5. msbrauer
    Member
    Posted 5 years ago #

    I managed to solve the problem by deleting the following flash code from the file wp-admin\includes\media.php:

    <?php if ( $flash ) : ?>
    <script type="text/javascript">
    <!--
    jQuery(function($){
    	swfu = new SWFUpload({
    			upload_url : "<?php echo attribute_escape( $flash_action_url ); ?>",
    			flash_url : "<?php echo get_option('siteurl').'/wp-includes/js/swfupload/swfupload_f9.swf'; ?>",
    			file_post_name: "async-upload",
    			file_types: "<?php echo apply_filters('upload_file_glob', '*.*'); ?>",
    			post_params : {
    				"post_id" : "<?php echo $post_id; ?>",
    				"auth_cookie" : "<?php echo $_COOKIE[AUTH_COOKIE]; ?>",
    				"type" : "<?php echo $type; ?>",
    				"tab" : "<?php echo $tab; ?>",
    				"short" : "1"
    			},
    			file_size_limit : "<?php echo wp_max_upload_size(); ?>b",
    			swfupload_element_id : "flash-upload-ui", // id of the element displayed when swfupload is available
    			degraded_element_id : "html-upload-ui",   // when swfupload is unavailable
    			file_dialog_start_handler : fileDialogStart,
    			file_queued_handler : fileQueued,
    			upload_start_handler : uploadStart,
    			upload_progress_handler : uploadProgress,
    			upload_error_handler : uploadError,
    			upload_success_handler : uploadSuccess,
    			upload_complete_handler : uploadComplete,
    			file_queue_error_handler : fileQueueError,
    			file_dialog_complete_handler : fileDialogComplete,
    
    			debug: false
    		});
    	$("#flash-browse-button").bind( "click", function(){swfu.selectFiles();});
    });
    //-->
    </script>
    
    <div id="flash-upload-ui">
    	<p><input id="flash-browse-button" type="button" value="<?php echo attribute_escape( __( 'Choose files to upload' ) ); ?>" class="button" /></p>
    	<p><?php _e('After a file has been uploaded, you can add titles and descriptions.'); ?></p>
    </div>
    
    <?php endif; // $flash ?>

    I'm not sure if it's a good solution, but it seems to work after a few tests.

  6. msbrauer
    Member
    Posted 5 years ago #

    I should say that that file starts very close to line 778 in wp-admin/includes/media.php . I say it starts close to that line because I've changed that file a little bit, so it might not be an exact line number.

  7. Morley
    Member
    Posted 5 years ago #

    I had the same problem, I made the changes as posted by msbrauer.
    Works great thanks.

  8. johnwar
    Member
    Posted 5 years ago #

    The easiest way try the plugin call "no-flash-uploader.php"

  9. inntell
    Member
    Posted 5 years ago #

    After upload I couldn't set align for the image from the Add Media section. I'm using wp 2.7

  10. inntell, separate issue. Make a new thread for better support, list your URL and any plugins.

  11. Rob Bee
    Member
    Posted 5 years ago #

    thank you...the crying has stopped...

  12. stickleback
    Member
    Posted 4 years ago #

    disable shockwave worked for me on FF

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.